Unable to log into website if prompted for authenticator

This is occurring in every browser I have tried. If you are prompted to confirm your login in the authenticator app when logging in, the page will reload as soon as the prompt appears on your phone, and will ask for your password again, and loop this behavior.

Edit: Clicking the option to use the code instead does nothing, and it will just ask for the password again.

1 Like

I would first reboot the pc to make sure you don’t have additional instances of either the launcher or the client active in the background.

I am also experiencing this issue. I can open the battle net app, but can’t login to the website it just refreshes as I click login and before I get a push notification to approve on my phone.

This is still occurring. It seems authenticators provide such good security that they just prevent logins entirely. The only way I can log into the website at all is by removing my authenticator, but then it logs me out if I put it back on.

Same. After logging in my password, before I can even hit my authenticator button, the page reloads. As a result, I have to remove my authenticator.

And yes, I’ve used different browsers, I’ve cleared cookies and cache. This has been going on for months now. I tried again today hoping y’all had fixed it, but guess not.

For everyone late into this topic still having these issues: It seems to be caused by the MetaMask extension. You can either disable the extension or change it to “only read the website data when you click the extension” on the options.