Unable to complete maw soul ash mission

When attempting to complete the soul ash mission, app has fatal error and crashes. All other missions can complete (sl,bfa,legion) other characters work fine too. Just the soul ash causes crash. Tried not skipping to end of mission and watch the whole "fight’ play out, freezes after enemy takes its first turn.
Also only one toon showed the “!” Denoting missions ready to turn in within the change character screen when i had assumed any toons with completed missions would show this now.


Same problem here.

Can’t complete the ash quests at all in the app.

Even deleted the entire app and reinstalled, but the problem persists.

Just experienced the same problem.

Also having this issue. It seems to occur when the environment cast goes off at both normal and 2x speed. Also fails with instant complete (I assume there’s a problem with the environment cast being calculated/processed)

1 Like

Same issue. Normally the mission would play to the end and then fail to progress once the encounter ended, whether normal, sped up, or instant finish. Last run I encountered a fatal error which caused me to be returned to the title screen. I tried again to finish the mission with the go to end button and it progressed to the previous fatal error point and froze again. Only happens with soul ash missions.

Same issue as well. Breaks the entire app after trying to find a work around for the singular soul ash quest and gives fatal error at login.

Same issue here, happens on the damage pulse.

Same issue for me on IOS. I can turn in everything except Soul Ash. Fatal error then crashes

same issue. after the mission has occurred, click to see how it turned out and it crashes. says fatal error and returning to title screen.

Seems to be fixed now!

Nope! Had 2 characters with the Soul Ash quest and fatal errors on both. Had it earlier in the week on a 3rd. I only do the xp and soul ash quests and only getting this error for the Soul Ash quest

Oh and this was on my iphone. All software updated when the errors occurred

Damn, sorry thought maybe they fixed it it for everybody. Mine was android. Would love to hear if any other android users still bugged.

Thats one reason i put in my phone type. I saw no one else had so far. :slight_smile:

still having this issue on multiple characters. one of them mysteriously completed after a reload but dont know why or how… other toons wont complete after reload, changing chars, changing expansions… nothing seems to get past this without going in game.

This is still an issue as of this morning. Any word from the blue?

Also having the same error on the same quest, clearly they broke something in the update, but probably aren’t even sure what given that the downtime Tuesday was considerably longer than they initially forecast… Also using iOS

Still an issue as of today. Just tried to collect and got the fatal error

Looks like they haven’t fixed the bug for IOS devices, then, because I haven’t seen this particular crash in a while in the Android version.

I’m experiencing the same issue.

IPhone with the latest IOS version.

Apparently it’s any quest with the Maw based rewards; I tried doing the stygia one and am getting the same bloody buggary fatal error as soul ash…. :face_with_symbols_over_mouth: