Unable to change pet name with or without add-ons

UI seems to be broke. Even with all add-ons off, right clicking on my pet gives it no option to rename it. I was able to change literally every pet name I have, even exotics. Now I can’t. Any reason as to why?

Assuming this is for Retail - have you been trying to with a Certificate of Ownership?


Have u tried a proper ui reset by deleting the wtf interface and cache folders.

1 Like

If you tamed a rare (i.e. Loque), they keep their names and you have to use a certificate of ownership. It seems keeping their names consumes the free name change normal tames get.


I’ve never needed one before. What changed?

Several years ago, the developers changed this I believe during the Legion expansion or even prior to that.


Wait, are we talking companion pets or hunter pets here ? I’m assuming, since this is the Pet Battles forum, OP is having trouble with a companion pet.

With the pre-patch, all sorts of stuff changed, some of which obviously wasn’t intended. I just tried a rename on a Feline Familiar pet and it worked normally, so really not sure what’s causing Dhaos’ problem.

Disabling your add-ons was the most likely cure but that apparently didn’t work. If you try Darthwraith’s suggestion to delete WTF and Interface folders, make sure to keep a backup. WTF delete loses the add-ons entirely, and loss of Interface data would wipe out any saved info like Rematch teams.

1 Like