Trying to unlock flying in Shadowlands

So I made a character specifically to unlock flying in Shadowlands through the timewalking thing. Went through the whole questline for each of the 4 main zones, after which I am pretty sure you are supposed to get a quest to choose a covenant/faction to grind renown for to eventually unlock flying.

Well here’s the thing…I never got that quest.

So I just started leveling with dungeons, figuring maybe it’s locked behind a level requirement. Got to 60 and still no quests have popped up. Now I’m double frustrated because I just found out you can’t stop experience gain at 60 (caps at 59), so now I’m probably going to have to make another character and go through all of those stupid quests again STILL ON THE GROUND.

This whole thing has just been frustrating as hell. Seriously making me regret playing again. All I wanted was to unlock flying in this last expansion that I don’t have it for (especially cuz it didn’t SEEM difficult - though the reality is proving otherwise) and maybe start farming some cool covenant mounts…

TLDR: not able to choose a covenant even after finishing all 4 zone quest lines and reaching level 60.

This article lists all requirements in order to unlock flying in SL.

It’s locked behind a couple things, none of which are completing the storyline of the 4 leveling zones. You don’t have to make a new character, just refocus on the actual things that unlock the quest for you. Renown, covenant campaign, and 9.1 campaign. :slight_smile:

You need to join a covenant to unlock flying, and you need to complete the Shadowlands campaign to join a covenant, so yes it is an indirect requirement.

If you can’t get the quest to join a covenant, try disabling addons:

I tried disabling all my addons and even relogged and still no quests are popping up to let me choose a covenant. Not sure what else to try at this point.

If I’m remembering correctly, only the Kyrian covenant questline requires dungeons, so if you pick one of the other ones, hitting 61 shouldn’t be an issue.

Have you tried going directly to Tal Inara to see if the quest is there? Once content is no longer current, the pop up quests are often disabled.

1 Like

I do not remember how…
A item I looted … I opened in my bag.
I could fly…
Not this account.
I do remember the toon was 60.

You probably started part of the quest chain then stopped it. Try figuring out where you left off the quest. Go quest-by-quest in a guide checking which ones you have completed. When you look at websites like, they have macros on the page of each quest that you can copy-paste into chat and it will tell you if you completed the quest or not. I’d start there by checking what quests you completed. Which I could help more.

By the time you unlock flying in the Shadowlands you’ll not see much point in being there anymore.

1 Like