Troll Feral Macro help?

So I am trying to cast Berserk and Berserking with 1 button. Neither on GCD, macro below requires me to push button twice, am I missing something?

/cast Berserk
/cast Berserking

Edit: Also tried /castsequence Berserk, Berserking

That “should” be fine.

Is one not going off with one push?

You may be hitting it too close to other abilities (being on GCD).

Neither are on GCD.

I did get it sorted out.

Berserking is troll racial, I added (Racial) behind Berserking and it worked!

/cast Berserk
/cast Berserking(Racial)

That’s what I was wondering.

Strange that the (racial) was needed.

Glad you got it fixed.

For future reference, I highly recommend shift-clicking abilities out of the spellbook for a macro. Basically, bring up your spellbook and macro pane in advance (side by side), then click inside the macro to bring up the cursor where you want it. Then shift-left-click on the spell you want to appear at that point in the macro.

I find that some spells have strange additional syntax with them (such as in the racials case), which automatically gets imported when you enter them into macros this way. Moreover, if you’re me, this has the added benefit of preventing misspelling an ability. 9 out of 10 times that I have a macro fail, it is user-spelling error.

1 Like

Always…ALWAYS shift click spell names from the spell book. It just makes life a lot better.