The Unseen Blade - Unable to complete, NPC not there

Basically I have tried all three artifact weapon quests and they all do not have a NPC to turn the quest into. I have the weapons equipped and turned off all add-ons and logged in and out and still there is no one in the Class Hall where the marker shows to turn these in, super annoying and basically I can’t finish the quests.

I have done this several times on other classes and there are no issues at all!!!

8 Likes

I have the same issue. On my horde rogue that has been inactive since Pandaria and picked up again. I am unable to turn in The Unseen Blade quest. Garona meets me at the top of the Violet Citadel stairs saying let’s meet in the hall, but there is nobody in her seat at the table. The only NPC present at the table is Princess Tess Graymane.

2 Likes

I am having the exact same issue on Garrosh with my 40 Alliance Rogue. I can’t abandon the quest, or destroy the weapon to try and pick it up again. Can’t complete it to move on to the next weapon. No add ons, went to Chromie and turned time walking on and off, logged out completely, and yes I am in The Hall of Shadows inside Dalaran via the Legion: Dalaran Hearth Stone.

3 Likes

Fill a ticket and gm will have it completed for you.

amazing so the rogue Class hall is broken at that point. Great.

3 Likes

Same issue here.

Edit: Opened a ticket and a GM completed the quest for me. :slight_smile:

1 Like

How do you open a ticket ?

In game under support. They will initially respond with a bunch of steps to try and fix the issue, none of them worked for me and it sounds like the folks above tried and didn’t have any more luck than I did. Average wait time on right now is showing 2 days and 6 hours.

Have this same problem :frowning:

NPC’s appear to be back.