The Marshals Grave

Currently stuck on the ready for war story line. I’ve gotten up to Marshals grave but accidentally abandoned the quest. Now I can’t seem to get it back. Any thoughts on how to do that?

Same here, I’m trying to progress in the BFA story and this is the next quest I have to do, I’ve got my Heart, I’ve done all the other Quests, and I’m Honored with the Honorbound, but it won’t pop up like it’s supposed to, I’ve tried talking to Nathanos but he doesn’t have anything for me, Is there something else I’m missing? I’m getting desperate and frustrated here

Have you completed Uniting Zandalar to unlock world quests? That’s the only other requirement that I’m aware of.

You can also try and go to where the quest would turn in to see if you can pick it up there.

It’s also possible that Blizzard broke stuff when they rescaled BfA, so if neither of the above work, I’d put in a bug report. (Either using the in game tool or by posting in the bug report forum.)

Yup yup done both of those quests
I tried that, no luck
Yeah i think that might be what happened, I submitted a ticket but I’m not holding my breath

Update here, once I reached Level 60 Nathanos now offers the quest “A Stroll Through the graveyard” allowing me to continue the War Campaign.


I can also confirm this. Once I hit level 60 I was able to pick up the quest. Although Im also at 5000 rep into friendly with Honorbound, not sure if that plays a role.

Thanks for this info dude, saved me a lot of frustration.