The fabulous miss fanny bugged?

i am playing on my rogue vulpera and i am currently doing the fabulous miss fanny quest in valley of the four wind. for some reason, i cannot pick up Pang’s extra spicy tofu. it shows as lootable but when i click on it no loot shows up.

Did you figure this out?

Having the same issue right now, I was able to pick it up the first time. Sent it down wrong, now I cant grab more to send it again.

I got it to work by abandoning the quest logging out and then logging back in and re-accepting it. Hope this helps


This quest is still bugged. The fix mentioned above of abandoning and trying again no longer works as of 11 March 2023. Please note this issue was raised more than 2 years ago.

With the quest up, try running away from the house/area towards the mountains, then run back…u will notice that the “objects” and Miss Fanny are gone but spawns in shortly after u return. Should be able to loot the spicy tofu again. It worked for me. Hope this helps!


I came here literally just now with the same issue and THIS is the one that actually worked. Thank you.

1 Like

For clarity, I walked away until everything despawned from the farm and came back and the quest was thusly unbugged for me.

Neither of those worked for me. I had tried the following:

  • Abandoning then Re-Accepting
  • Running away until all but the building had despawned
  • Abandoning then logging out for roughly 45 seconds

What did work? No clue, I was frustrated and spam clicking on the tofu when it randomly gave me one.