Stuck at Logging into Game Server. (25 MAY 2024)

We’re on this again…

‘Logging in to game server’

Restart PC, reset router, ipconfigrelease, renew, flushdns…

Still nothing.


Same issue here.

i just wanna play the game

Can’t log in as well.

Still having the same issue on two computers.

Is this happening to all of your characters? I am having the same issue but only on some characters. Remix, no issue. Any of my characters that are in Stormwind or Valdraken can’t log in. I get a streaming error 51900322. Orgramar, works.

I cannot log in on anything.

I am also stuck at “Logging into game server”. I first tried 3 hours ago, I have restarted my computer and the router with no difference.

Same issue for me it has been going on for about 5 hrs. There have been a couple of times it will make it to the remix page where you make a character then it tells me i don’t have dragonflight.

Same issue for me in retail and classic

Same. Tried logging in about 3 hours ago after a short update and it’s been stuck ever since. :unamused:

any have the solution? pls

same issue here stuck at logging into server and if it does make it to that nothing comes up in the character screen very frustrating.
Been this way since atleast 430am pst.

Previously this was an issue with everyone who had TDS internet can anyone confirm if thats what they have same issue here…again 4th time

same issue claro telmex colombia pingplotter /MGLNqSLzCF6 please @Blizzard solve soon as before

I had the same issue back in December. Can confirm, I do have TDS.


I have Comcast internet. WoW still isn’t working. It was fine last night, I don’t know what could have changed since then.

Haven’t had this issue before, But been consistent for me for roughly 5 hours. Also have TDS

My fiance and I are also having this issue. We reset the router twice, called TDS and they claim it’s not them. I am able to use my moms internet (Spectrum) and it works just fine. As far as the TDS issue goes, it will let us log into the classic games but it will not allow remix/live/cata.

Yep, I had the same thing a while back and happening again. I have TDS.