Stuck at "Logging in to game server"

Was playing just fine and then got a massive lag spike, game recovered and about 2 minutes later another spike that disconnected me from the game. Ever since I have been stuck at “Logging in to game server”, I am able to connect to other Bnet games and other games that I own. Just having connection issues with wow.

1 Like

I’m having the exact same issue. Going on two hours now. :frowning:

Two of my friends are fine and me and two others can not connect. When we tried to ping the server we’re getting “Request timed out”

Same situation for 2 PCs in the same house here, same time period. We are in the Northwest US.

Same issue, 1 week here… i mean, i can log in but loading bar in character selection is stuck at 50% and i cant click enter or create a character…

Same issue. I got disconnected around 4-5 hours ago while playing mop remix and haven’t been able to log back in, stuck on on “logging into game server”, of course. Other people don’t seem to have any issues.

Woke up this morning unable to log into Cataclysm Classic stuck on "Logging in to game server” However we can play the MOP or Normal Retail WoW just fine. Going on 2 hours of unable to log into the Classic side.

Same for me. “Logging in to game server”

I am able to connect using a VPN out of Canada…

Its been five hours since the OP and I’m running into the same issue since I woke up this morning.

Same thing here. Odd is that I am trying to log into cataclysm and I have a battle.net account with 2 different wow accounts. One account logs in fine and the other just sits at the logging into game server screen. I tried the account that was having issues to log into sod and it logged in fine.

Edit: I will add that I do have TDS. The account that is working was pointing to a west coast server at login. The account that was not working was an east coast server.

Same thing here, i logged in yesterday like normal, now i cant log in im just sitting on the login screen while all my other games from blizz and otther companies are just fine

This happened before do any of you use the ISP TDS for your connection

Bumping this comment again - TDS user here.

Yep still stuck. Opened a ticket, as useless as that is. Nothing they have suggested so far works. Our little isp got sold at the first of the month, pretty sure its not TDS though. We have 2 computers on the netork and 2 accounts, both in the same boat.

Same for me. Sooo frustrating…

cant log into any wow version as well

Same thing just started to happen for me. Was working fine yesterday

If you’re using TDS as your ISP, it’s important to alert them of the issue reaching a specific regional server. Blizzard won’t be able to contact them on your behalf.

1 Like