Still no fix for installing Battle.net? What the heck Blizzard? Stuck at 45% like everyone else

This is a tad bit ridiculous at this point Blizzard. This is obviously an issue that has been around for months and there’s still no fix.

I’m using an M1 Pro MBP and running the latest version of Mac OS. I’ve deleted every single file that has ‘battle’ in it, emptied my trash, and then restarted my computer multiple times. It still hangs at 45%. Would be really cool if Blizzard actually paid attention to these forums and fixed this…

4 Likes

Same issue for myself. Update is stuck. Nothing fixes it. Saw a blue post from about 2 days Mac OS Team is aware no eta on fix though. Hopefully it comes soon.

1 Like

I wouldn’t hold my breath. Blizzard doesn’t seem to care too much about fixing their installation and update issues. I may just build a PC at this point. My M1 Mac is for work but it’s more than fast enough for WoW so I was hoping to use it.

PC users seem to get stuck at 45% as well but deleting any of the battle.net files and trying again seems to do the trick for them.

It’s riddled with permission issues. if you just grant the permissions yourself in macOS security settings for app to give it file permissions it generally still works. But yes, the battle.net app and agent sub process are some of the worst coded apps I’ve ever seen, mac and windows. worse on mac

1 Like

Apple Developer here.

Can confirm.

1 Like

That would work if I could get Battle.net installed in general but I can’t.

1 Like

I can’t figure it out and I have technical knowledge of macOS lol. The Battle.net Setup.app runs but doesn’t appear to actually write anything to the hard drive. I’ve tried running it in terminal with SUDO and still nothing. I open activity monitor as it runs - zero disk read/writes from it. I’m not convinced it’s doing anything.

does it write to your shared folder at least? mine does but that’s it. it also seems it wrote to my actual app data folder the first time I tried it yesterday but after deleting that data and trying again, it never writes there anymore, just to the shared folder for a split second until it hits 45% and then stops.

I have fixed the issue. See my post history for the thread.

Nothing worked for me. I tried running from command line with a couple different flags. I tried downloading an older version. I then tried a VPN. Then I tried tethering to my phone. Lastly I tried on another Mac. All fail at 45%. Clearly it’s blizzard.

1 Like

So the steps have worked for the 6-7 people I’ve already gotten it to work for are:

Delete everything.
Install old version.
Let old version hang at 45% and then kill it with Activity Monitor
Install new version, hang at 45% and then kill it
Command line.

Things that may stop it from working are firewall, router, anything with NAT. VPNs and not having full disk perms or “everyone” set to read/write for the installer.

Developer here… checking logs in /Users/Shared/Battle.net/Agent/Agent.8550/Logs

[I 2024-01-21 20:01:44.0073] Duplicate POST /install/battle.net completed in 0.9950 ms
[I 2024-01-21 20:01:49.0121] Duplicate POST /install/battle.net completed in 0.6360 ms
[I 2024-01-21 20:01:54.0171] Duplicate POST /install/battle.net completed in 1.3000 ms
[I 2024-01-21 20:01:59.0220] Duplicate POST /install/battle.net completed in 0.5930 ms
[I 2024-01-21 20:02:04.0269] Duplicate POST /install/battle.net completed in 1.3710 ms
[I 2024-01-21 20:02:09.0315] Duplicate POST /install/battle.net completed in 1.1290 ms
[I 2024-01-21 20:02:14.0360] Duplicate POST /install/battle.net completed in 0.5760 ms
[I 2024-01-21 20:02:19.0412] Duplicate POST /install/battle.net completed in 1.3000 ms
[I 2024-01-21 20:02:24.0458] Duplicate POST /install/battle.net completed in 0.6290 ms

This repeats

If you read the logs they read like this (shortened) (sorry no links)

  • Checking Network Connection status to patch (dot) battle (dot) net
  • authorize sessions to patch server
  • Get /game/agent
  • Register product
  • Get the install torrent
  • Then it falls into the loop I quoted above

This makes me think it’s not a file permission problem but a torrent download problem from the patch server. Every once in awhile it does succeed and gets this response (also shortened)

  "background_download_available": false,
  "background_download_complete": false,
  "background_download_progress": 0.0,
  "binaries": {
    "game": {
      "launch_arguments": [],
      "regex": "Agent\\.(%d)*\\\\Agent\\.app",
      "relative_path": "Agent.app",
      "switcher": true
    }
  },
  "binary_launch_path": "",
  "binary_launch_path64": "",
  "branch": "",
  "current_version": 8550,
  "download_complete": true,
  "geo_ip_country": "",

You see the folder it wants to write too but you also see the 0% file download completed.

Is it Mac Permissions for torrent downloads from a file in /Users/Shared? Maybe…

scratches head, why not a simple .DMG and drag and drop? Why am I looking in /Users/Shared?

2 Likes

And right after I write this I found someone posts a solution

1 Like

If you look at how the application defaults to running, it runs the application or tries to unpack/run it in Rosetta from /var. I think that’s the critical problem. Because in the BC-XXXX log files it says something about read-only file system. I didn’t really examine this problem very closely. I just sought to find a solution to it. But looking now, I think that’s part of the problem. How they run Rosetta and how/where the app is run.

1 Like

Ran into this issue today on Windows. Nothing has worked so far.