[SOLVED] WoW & GPU Timeouts

Hello, everyone!

Over the past 11 months, I experienced constant and random GPU timeouts while playing any installation of WoW; whether it be retail or classic. Throughout this time period, I literally tried everything to remedy the situation. Thankfully, however, as of 2 weeks ago, I have finally found a fix (that works for me, at least).

Symptoms

  1. The display freezes for ~5 seconds but can still hear all sounds (game, videos, Discord, etc).
  2. Display goes black for ~5 seconds.
  3. Display typically recovers but have had to hard reboot.

When it started
It began almost immediately after installing AMD’s 7900 XTX. Previously, I was using the 6800 XT without issue. Though, strangely enough, when I went back to my 6800 XT, the issue persisted, making me question if it may have started with the new drivers that AMD rolled out with the 7900-series cards. However, I tried my brother’s NVIDIA 3080 Ti and the issue was still present.

What I had tried

  1. Upgraded PSU from 850W to 1000W
  2. Disabled integrated GPU
  3. Installed RAM specifically made for AMD CPUs
  4. Used DirectX 11 mode in WoW
  5. Enabled AMD EXPO (6000MHz)
  6. Unplugged external HDD
  7. Disabled AMD Noise Reduction
  8. RMA’d 7900 XTX
  9. Tried several GPU driver updates
  10. Minimal installation of Windows 11 (drivers, firefox, discord, Logitech G Hub, and WoW)
  11. Tried multiple BIOS updates
  12. Installed RAM listed in motherboard’s RAM compatibility list
  13. RMA’d motherboard
  14. Unplugged Corsair Commander Pro
  15. Uninstalled iCue
  16. Unplugged AIO CPU Pump from USB header
  17. Disabled FreeSync (both on monitor and in AMD software)
  18. Increased TDR delay in registry
  19. Disabled MPO
  20. Disabled Smart Access Memory
  21. Tried multiple chipset driver updates
  22. Tried only using 1x stick of RAM (16GB)
  23. Set PCIe slot to Gen4 in BIOS (from Auto)
  24. Set PCIe slot to Gen3 in BIOS
  25. RMA’d CPU
  26. Set monitor’s refresh rate to 240MHz
  27. Monitored RAM and VRAM utilization for discrepancies
  28. Tried AMD Ryzen 7 7800X3D
  29. Updated Corsair RAM firmware via iCue
  30. Ran WoW with no addons
  31. Tried clean minimal installation of WoW (empty Interface folder and default WTF folder)
  32. Set in-game FPS limit to 60 fps
  33. Set in-game FPS limit to 120 fps
  34. Reduced RAM speed from 4800MHz to 3600MHz
  35. Enabled virtual memory on NVMe drive that WoW is installed on
  36. Followed JayzTwoCents video on correcting TDR issue with DDU
  37. Removed all NVMe drives and used SSD
  38. Monitored AC voltage from wall receptacle
  39. Plugged PC directly in wall (instead of power strip)
  40. RMA’d PSU
  41. Many other tests that would take too long to explain

The main struggle with all these tests if the GPU timeouts would happen anywhere from multiple times a day to nearly a week. So a test that showed promise would have had to make it to 7 days without a timeout.

With my latest change, it has now been 2 weeks without a GPU timeout.

The Solution
Initially, AMD stated that the RAM speed “sweet spot” for the Ryzen 9 7900X was 6000MHz, which I had tried in test #5 with no success. I recently discovered on a YouTube video from ErockOnTech that AMD had changed this value from 6000MHz to 5200MHz. Turns out that most CPUs from AMD and Intel list the recommended RAM speed.

So I enabled AMD EXPO in my BIOS (which default speed is 6000MHz) and manually changed the speed to 5200MHz.

Hopefully this solves similar issues for anyone experiencing them.

NOTE: There was a YouTube video that I followed to apply additional settings for optimal AMD 7000-series CPU settings. You can find it by searching “[2023] Optimizing Ryen CPU Performance: Best BIOS Settings for 7000 and 3D Series” by the YouTuber Kephren.

1 Like

Yeah ram OC profiles can definitely cause random headaches like that for sure. Honestly though, you aren’t losing out on much by dropping to 5200 from 6000. Might not even be a half of a percent difference, probably even less for gaming.

Also, for future reference, sometimes you can avoid having to reboot the PC after a driver crash recovery by pressing start+ctrl+shift+b. You’ll see the screen blank black and hear a beep if you have sound on.

But wow, that’s a pretty extensive amount of things to try ruling out. You get my stamp of approval!

2 Likes

I have some doubts that the issues many of us have been having with DX 12 Gpu driver crashes will be fixed by changing ram speeds to 5200, but im testing it now and will see if i have any crashes.

1 Like

5200MHz may not work for you. You’ll want to consult the specifications page on your CPU manufacturer’s website for the recommended RAM speed for your CPU (unless you are using the same CPU as me, that is)

I use a 7700x and its been recommended for me to use 6000mhz as well which i have been. The issue that has been occurring for many people now in multiple threads is that when using DX 12 we are experiencing gpu driver crashes randomly. Using DX 11 however crashes never occur, but im testing this ram solution as nothing else anyone else has tried has worked at all for the issue so worth the try.

Just looked up the 7700X on AMD’s website and it also states a max RAM speed of 5200MHz when using 2x sticks of DDR5; 3600MHz when using 4.

Crashed within hours of trying this solution, sadly didnt work for me.

how many sticks of DDR5 do you have?

If it makes you feel better, this crap plagues me too.

AMD 5800x3d & 7900XTX

I went into MSI B550 motherboard and enabled XMP profiles and set the DDR speed to 3200 like you said, I even ran a full memtest afterwards which passed

A day later under DirectX12 I had the black screen driver timeout

Put my settings back to DirectX11 and its fine again

Unfortunately this just didnt work for me

Seems like op just had a separate but similar issue. One big common trend seems to be 7000 series cards having issues with DX 12 since 10.1.5.

Hi Blizzard, AMD won’t address this issue, We are counting on you as developers to reach out to AMD and work on a fix. We are buying top end hardware (7900 XTX) to play your game without issues, but we are beholdent to the worst kind of issues (constant crashes) Please respect us and work to help us. We don’t have reach to AMD like you

2 Likes

I really hope they do, or hope they are already working on one. Would be a shame to be stuck on DX 11 for even the next expac.

Just an update. This fix has resolved my issues in retail WoW but after playing Season of Discovery, the issues still persists in classic WoW.

I get these issues with an Nvidia card (2070S) and an AMD CPU (Ryzen 7 3700x).

Example: www.youtube.com/watch?v=jrwk14M-72k&ab_channel=Duninn

I just think AMD CPU’s are not optimized for WoW at all. Getting so many issues it is disheartening

Just out of curiosity, Have you tried 5800 mhz, 5600 mhz before dropping all the way to 5200 mhz? You are giving up a lot of performance with that much of a drop. The new bios for the x670 boards have made ram for stable for these chips

Interesting. I’ve just now updated my BIOS and bumped my RAM speed up to 5800MHz. We’ll see how this goes.

Let me know please

So far so good, though a “good test” is typically observed when no GPU timeouts occur for at least a week (which is exhausting, lol). If/when a good test is observed on retail, I’ll do the same test on classic.

Not only does this not work, but it isn’t even the cause of the issue. EXPO disabled, timings, or enabled have nothing to do with this crash.