[Solo Scenario] Stormsea Landing stuck at Stage 3

The solo scenario that is started from the quest Decisive Actions becomes stuck at the transition to phase 3 which is where your character and the NPC Taoshi are dropped onto the boat to wreak havoc.

Taoshi never makes it onto the boat and the scenario requires you to stay with her.

Restarting the scenario doesn’t help nor does dropping and picking up the quest again.

2 Likes

im having this exact same issue

Same issue for me on my Warlock. “Decisive Actions” is part of the introductory quest-line for the Isle of Thunder, so this blocks the whole zone’s quests. I’ve tried the scenario about 6 times, and every time, as described above, when she drops you on the ship at the start of phase 3, she disappears.

I am having the exact same issue

Got this problem too.

Taoshi don’t jump in the boat and i can’t complete the quest. I even killed all the guards all by myself (after 30 long minutes of fight) and there is no interaction with the weapons aboard.

Any solution yet?

After some back and forth with a GM, the GM “finished” the quest for me.

Whether or not fixing the problem is on someones plate is unknown.

Figure a couple of days to resolve if it happens to you.

Idem here. Im stuck in that phase too :S

Same issue. Unable to complete the scenario and quest with no Taoshi.

Can confirm it is still happening. Have ticket open.

Isle of Thunder: “A BOLD IDEA” scenario quest – stage 3

… Taoshi drops me off at the ship, then disappears; nothing I’ve tried has worked to get past this stage of the scenario: ex.

  • I’ve waited for her to reappear
  • restarted scenario (several times)
  • tried different character (same account)
  • tried different character (different account – I have 2 WoW accounts)
  • deactived all addons
  • reset game options to default
  • renamed (removed) [/Interface] & [/WTF] directories
  • scanned and repaired game files
  • waited for weekly reset

… nothing I’ve tried works to fix this

Happening to me too, this sucks

Same issue, same stage in phase.

It seems to be working now, just competed it

FIXED!
… this morning noticed a game patch download & install; stage 3 works now!

1 Like