Scar 18, 'unable to change display mode'

When launching WoW through the battlenet app, my laptop says ‘Unable to change display mode’ and when I click for details it shows applications blocking display mode change there’s 5 listings of

I can still play WoW with what I assume is the integrated graphics and I can still manually switch to optimus or nvidia gpu only in the nvidia control panel…

But up until a few days ago it automatically switched and never had an issue. What is going on?


Same. It just started happening.

1 Like

Same here. I have to let the game load then exit out of entirely / close the app for it work. That way it switches properly. It happened to be since the latest patch :confused: So I have to exit out of it after the game for it to switch and it’s weird. I tried to switch manually, but it crashed the game :confused:

1 Like

I am having the same issue as described by the OP

Chiming in because I have the exact same issue and it started December 2. Lists “” 5 times.

I have the same issue :disappointed: I have a Lenovo Legion 7i

1 Like

Same issue with all other Blizzard games. Ow2 and D4 suffer frame drop frequently.

Same issue for me. Mines a 3070, and Alienware x17. The issue started today for me. Yesterday was working fine.

I can manually swap same as everyone else but the auto swapping gets blocked by the app.

Can all of you please post a dxdiag to past bin and post the link here

## DxDiag

1. Press Windows Key + R.
2. Type DxDiag and press Enter.
3. In the DxDiag window, click Save All Information.
4. Name the file "dxdiag" and click Save.
1 Like

Here ya go.

While it looks like you are using the latest Nvidia driver have you also updated you Intel GPU driver?

same problem here. only way ive noticed getting around it, close battlenet before WoW gets a chance to start up.

I am up to date with all of the Dell updates.

This is the download link for the latest Intel GPU driver for your CPU

Will this fix it? Should I not use the OEM driver?

OEM drivers are generally very far out of date. While your NVidia driver seems to be the current one the Intel GPU is very out of date .

It is possible it will fix the issue.

Same problem here. All updated drivers. And nothing seems to work to fix it besides just exiting out of

1 Like

Thanks to your directions, I ran DxDiag and have it saved. Can you please walk me through the steps to post it here?

You will want to post it on paste bin and then just post the link in your post.

There is mine to see why it’s not switching over properly.