Retrieving realm list

i cant even get the character screen.
all i get is retrieving realm list.
options? lag? servers down?


Have you made sure that your WoW client is up to date by checking the app?

same problem to u .
just happened 10mins ago.

Had the same issue, I just let it sit there for like 4 minutes and it finally loaded. Tried to relaunch, check for updates, etc. nothing worked. Just AFK for a few.

Yep same issue here, seems to be an issue on Blizz’s end.

Same here sucks :<

*Australia - TPG - Barthilas

1 Like

Could also be network interference-- nothing Blizzard can do about that, if it is. The Northeast is starting to be tickled by a five-day stint of rain and heavy winds.

Who’s from where using what ISP? Might help find a connection.

edit: nevermind, while i was typing this it brought me to the character screen

same here… and when i try to log in from the game itself. it says suspicious acitivity. account locked

Yours is a different beast, entirely. Suspicious activity usually references account access outside your normal location.

Trying to logon to Aman’Thul: Retrieving Realm List > You have been Disconnected (BLZ51903006).

No, i am having the same problem while retrieving realm list. so i tried to type in creditials after i click cancel. But even it say so, my account is still not locked

I’m having the same issue (Frostmourne server)… Retrieving realm list > Logging into Game server > You have been disconnected (WOW101331…)… happens over and over… even when I leave it for a while. Doesnt seem to connect. Whats the deal?

It is happening to me too. I tried to switch realms while in the game and it never would. So closed the game and restarted. It returned to that realm (Maiev) but it will not let me switch to another.

Now it says “Some realms may be unavailable”

UPDATE: Finally got it to switch to Bloodscalp. Here’s hoping I can switch back to Maiev in a minute.

EDITED TO ADD: I am East coast US.

Same trying to log on to Aman’Thul getting stuck Retrieving Realm List then DC

Also can’t connect past retrieving realm list. Oceanic Area.
Realm Barthilas

winMTR: h ttps:// delete the space

Same here in Tasmania

Your not alone, east coast here. Sometimes I get in sometimes I get the standard you have been disconnected error

Having same problem in perth I guess we all have to wait until blizzard fix

Yep can’t log in barthilas oceanic