Really Weird Macro Quirk

I’m looking to see if anyone knows why this is doing what it’s doing. I’ve got a mount macro and after they made the Dalaran Hearthstone a toy, I rolled it into it to save action bar space.

/use [nomod,btn:2] Dalaran Hearthstone; [mod:shift,advflyable] Renewed Proto-Drake; [mod:shift] Explorer’s Jungle Hopper; [mod:ctrl,btn:1] Lucid Nightmare; [mod:alt,btn:1] Running Wild
/dismount [mounted]

Shift = Renewed Proto Drake if advflyable is true (I haven’t updated this since DR mounts were allowed outside of the DIs), otherwise Explorer’s Jungle Hopper.

Ctrl + M1 = Lucid Nightmare

Alt + M1 = Running Wild

No mod, M2 = Use Dalaran Hearthstone

Very, very simple macro as you can see. It works as expected for every character I have save for my DK. For her and her alone to cast the hearthstone it requires right-clicking twice. Every other character right-clicking the macro button starts the cast. On her right-clicking does absolutely nothing until I do it a second time, then the cast starts.

This has boggled me. There is absolutely no reason I can see why this behaves this way. Every time I’ve got to double right-click just for her it annoys me again. Anyone have any ideas?

Does the GCD get triggered the first time you use the macro on your DK?

This is my mount macro for all my toons (with some variation on mounts chosen):

/use [mod:alt]Grand Expedition Yak;[mod:shift]Renewed Proto-Drake;[mod:ctrl]Traveler's Tundra Mammoth;[indoors]Carcinized Zerethsteed;[outdoors]Deathlord's Vilebrood Vanquisher
/dismount [mounted]

I changed it to the following for the Hearthstone on my DK to test and it worked just fine, 1 button push:

/use [mod:alt]Grand Expedition Yak;[mod:shift]Renewed Proto-Drake;[mod:ctrl]Traveler's Tundra Mammoth;[indoors]Carcinized Zerethsteed;Dalaran Hearthstone
/dismount [mounted]


I wonder if there is something different about your DK’s UI that is causing some weird behavior.

If you turn off all addons on the DK and set the edit mode UI to the default, does that change anything? If that fixes it, then the next step is troubleshooting aspects of their regular UI.

No, the GCD isn’t triggered on the first click. It just acts like I did nothing until the second click. And when I do, it’s faster than the GCD anyway and then it works fine.

Nothing’s different on her from any other of my characters. They all have the same addons loaded. They all have the same UI options set. This is why it’s boggling me. There’s no logical reason I can see for this to behave differently on her. But there’s been weird UI bugs before, like the one where overwriting one of the default camera views quick setting with a custom one would break camera follow until you reset it back to its default. That was broken for at least decade and a half before Blizzard finally fixed it in DF. And I was starting to wonder if this is another weird one.

I’d recommend using /fstack and mousing over the action button while logged in to your DK. There may be some other UI element intercepting the first click.

To eliminate most potential UI variations, try doing a temporary UI reset by renaming the Cache, Interface, and WTF folders and then starting the game. Try the same macro on the DK and on a character that the macro worked for before and see if the UI reset helped the DK work.

If it doesn’t change anything, just delete the new WTF, Cache, and Interface directories and rename the prior ones back to their original names to restore your earlier UI.

  • Do the mounts also require a double-click or just the Hearthstone?
  • If you switch it to a different hearthstone toy (Garrison etc.) does it still require double-clicking?

The macro works on a DK so the problem would seem to be either the action slot or something with the way the macro is saved.

First, try moving the macro to another slot well away from the current one. If that doesn’t work, try creating a new macro (maybe character specific) without copy/pasting the current one (you can copy paste from your forum OP).

No, the mounts do not require double-clicking. I’ll have to check with another hearthstone toy next time I’m in to see if the action remains the same.

Like a few other class-agnostic, shared macros, I use the same slot on all my characters for it. I can only think of a couple where I don’t, and it works fine on them as well. I can try another slot but I honestly don’t think it’s going to do much.

As far as copy/pasting the macro from here, here’s the thing. I actually have three versions of this macro. They are identical except for the specific dragonriding mount it summons. This is the Protodrake version, and the other two are the Slitherdrake and Highlands Drake. They’re all copies of the same macro with the different dragons substituted. I only use one dragon per character, and those are the only three dragons I currently use. And whenever I do longish macros I don’t bother doing them in game but rather write them directly to the macros-cache text file in the WTF folder with a text editor, which is infinitely easier than trying to squint at the tiny font in the in game macro editor window.

And the same macro with the Protorake works completely fine on other characters. The exact same macro that screws up on the DK. It’s low-key driving me nuts.

The actions I suggested are purely for testing to try and narrow down what might be the cause of the problem, not intended as a final solution.

Although, if the copy/paste works then that WOULD be a final soultion :wink:.

1 Like

Deleting and re-creating the macro as-is is worth a shot, but I suspect it won’t resolve the issue in this instance given the other behavior. That said, it’s way less effort to try than literally anything else.

1 Like