Quest "The Horde is Family" bugged in MOP REMIX

So, this is what happened. I was doing my campaign quest for landfall in the part where you use Voljin’s Hearthstone and gets transported to Durotar. But, somehow, while I was escorting Thrall, he bugged and disappeared, so I had to leave the quest to get him again, but I was summoned to the Raid i was queued, and now I can’t get back to Durotar (because i’m leaving pandaria and get summoned back) and I am not able to get the quest anywhere else.

3 Likes

Yup same here. I tried abandoning the quest and it just put me in a worse situation. I submitted a ticket and Blizzard’s response was basically:
“Yeah we’re really busy right now, have you tried googling it? You should check out wowhead they’re so helpful!”
Embarrassing response. Even better when its blocking an achievement needed to buy certain transmogs.

Pretty much the same thing happened to me but I’m stuck in pandaria and the quest is in the valley of trials and I have no way of getting over there, I’m guessing the portal doesn’t work because of I made a time runner character

Yeah, In the same boat. Pretty annoying to have a quest be so bugged. I haven’t abandoned since it sounds like it makes it worse. Hopefully a fix soon

Same thing happened to me. I got a response. it told me to drop and pick up the quest. did not help. still cannot do anything

No response from Blizz yet when que quest will be fixed.

I’m having the same bug, I can’t get back to durotar for the quest, I don’t have the hearthstone that let me go there, and no way to get the quest again to continue.

Like, I’m fine with not being able to go there when I don’t have the Pandaria quest that sends me there, or leave the area of the quest, but when it’s a major part of one of the chapters of the expansion, it should be possible for me to go back to where my quest is.

2 Likes

Having the same issue here, I got a response from blizz saying they know its a problem, and linked me this thread actually. They dont have a fix for it yet apparently.

1 Like

At least we know they’ve noticed it at this point. Progress.

Any news on this, Blizzard? I’m still waiting to do my quest and get my Class armor set!

Same boat as everyone else. Hoping a fix comes soon.