Quest Bugged: The Bad News (82022)

Quest: The Bad News… (82022)
Location: Booty Bay, Stranglethorn Vale
NPC: Injured Gnome
Issue(s): Talking to the injured gnome does not trigger the completion of the quest, nor gives the following quest The Lost vambraces

I’ve also encountered this bug - I’m on The Bad News quest and received the Decharged Void-Powered Vambraces - which shouldn’t be allowed since it’s the next quest chain The Lost Vambraces - so I can no longer proceed in the chain.

Having same issue. Picked up the quest from Moonglade, spoke to the injured Gnome in Booty Bay, clicked the dirt pile on Jaguero Island, and received nothing and no follow up quest from the gnome.

Update: I fixed the issue but not exactly sure which changed was the resolution.
Deleted Cache folder > Abandoned quest > Picked up from Moonglade again > Spoke to injured Gnome > Selected the dialogue option first > Accepted “Vampiric Bracers” quest

I abandoned quest and got the shadowy figure to give the quest again - back to STV and the gnome still doesn’t give the next quest - very frustrating to go back and forth. I will try to delete the cache folder and attempt again…

I’ve attempted to Abandon > clear cache > PIcked at Moonglade > Spoke to injured Gnome > Selected the dialogue option first > and nothing
Even attempted to clear cache while in STV and still not fixed

Ive done this, hes given me the bracer’s once but did not prompt the next quest in the guide. I deleted the bracer’s and my cache and now he doesn’t even give me the bracers. I’ve talked to the shadowy figure, the injured kgnome, the little bitty murlock, the freaken mound next to him. ITS BUGGED BLIZZAARD, fix your game!

Same issue here, he gave me bracer the first time and I went to the island but couldn’t get the follow up…I have opened a ticket but average wait time is 6 days 22hrs at the moment.

Can anyone look at the restoration service and see if the bracers are available to any of you guys having this issue ? Mine is on Cooldown but I was wondering if that might be the issue!

I have looked at the restoration page and “deleted quest items” are not a restoreable item uinfortunately =/ I was one of the first to have this issue. Posted about it on Reddit, opn the Forums, on WoWhead. still nothing. Been waiting 4 days on my ticket, and says 5 days 22 hours. What really sucks is I found a guy on the forums that it happend to aswell, and he was able to get it resolved the same day it happened by a GM just resetting the quest for him…

I had this happen. THE GM response was to get lost.

oh boy… i swear… I have been so annoyed by this questline I dont think I could handle it. I got into ST completed it week 1, had everything ready. got all my nightmare seeds and felcloth ready to go and try hard it out with my guild. but no. Im the only one this happens to… I would loose it… I already pretty much did at the automated response… Recommending things that anyone whos played the game longer than a few months and has a brain would know how to do to troubleshoot an issue like this… like come on. Blizzard needs to hire more GM’s and bring actual people back into employment instead of these damn BOTS that cant help worth a damn.

This unfortunatley does not work Triz. Thanks for the effort. But just tested this method and no dice.

EVERYBODY, I have just spoken to Aggrend. And if you Completed the quest for the vambraces and abandoned it. They can be rebought again through the Lost and Found Vendor in Booty Bay. If youre having the issue with the gnome not giving you the second dialogue option go and check there. As that will most likely fix the issue.

1 Like

Thank you for your post! This got me back to moonglade and was able to finally turn the quest!

1 Like

I’ve also spokent to Umkellxye, who basically redirected me to the same solution.
It fixed the issue and I can proceed with the quest!

The lost and found vendor fixed it for me, i was able to clear cache, buy my bracers and then go the moonglade to turn in the bracers.