Quest Bug: Cannot teleport to Gnomeregan

I cover most of here it BUT Ill text about it to give more information.

Basically because I did a level 48 quest in SEARING GORGE, I cannot do a lvl 25 quest for Gnomeregan. I would love for just a GM to HAND me a Goblin Transponder, but The GM couldn’t really help me. Just pointed me here.

WARNING: I just had a GM confirm that this quest ( ) is the one that BUGS the Gnomeregan teleporter quest line!!!

If you complete STOLEN: Smithing Tuyere and Lookout’s Spyglass before you complete Chief Engineer Scooty, you can NOT pick up that quest anymore, and you will NOT be able to get your Goblin Transponder, in order to teleport to Gnomeregan

MAJOR BUG! Goblin Transponder. Classic WoW (Chief Engineer Scooty)

This is very important for A LOT of Druids looking to farm Manual Crowd Pummeler, and makes it feel very unfair for me, now I have to RUN to there every time I go which is quite the hike.

If there is any additional information please let me know… Thank you! :3

This is an obvious bug that’s been in the game for months, fix this already.

I don’t see why a GM just can’t spawn the item for you, sheesh. It’s not like you did anything wrong.

Is this a horde only item? Didn’t know it was in the game, it’s kinda cool

By Lurker37 on 2006/07/01 (Patch 1.11.1)
Subject: "Known Bug"If you complete the quest STOLEN: Smithing Tuyere and Lookout’s Spyglass ( ) Then you cannot start this quest chain

If this is your situation, then a GM in game can ‘restore’ the item to you, as you will otherwise never get it, but most will not do so without intervention from Blizzard customer service.

Just be careful not to lose it, as I doubt the NPC will replace it for you.

It will be interesting to see if they will include this under their “‘Not a Bug’ List”. It seems like this bug is consistent with vanilla (possibly for 1.12.1), but the GM not assisting you is inconsistent with vanilla…

It was changed at some point (1.6-1.10) to where the NPCs involved in this quest line became associated with the Horde (although their nameplates still identified them as … Booty Bay?). Prior to this, you could complete the quest. For those of us on the Alliance side who completed the necessary change prior to the NPCs being changed, we were able to keep and use our transponders. It was nice to follow gankers through the teleporter :smiling_face_with_three_hearts:

It could also be used for easy/fast transport from Booty Bay to IF area. It still makes me sad it’s unobtainable for Alliance now.

1 Like

yes its horde only because alliance can just walk into gnomer

Teleporting is faster than the walk though

Still, it’s horde only

Dang horde

Yeah we can’t even get the quest for the transponder and it’s been months…

Can confirm Blizzard WILL NOT assist with getting a transporter / reset quest etc. Its obviously a bug but they just do not care. Really poor customer service, something expected from Blizzard at this point I guess.

I had this exact same issue in vanilla and classic both. Both are complete bs answers.

In vanilla the GMs had the ability to restore lost/incomplete items and would mail them to you as a workaround.

They refuse to give GMs in classic the same access so they literally can do nothing but blame their devs.

That being said I ran around with the rigs wars quest in my quest log for the last 3 months and recently went over to grab a blacksmith hammer to make an arcanite rod for a customer and the quest magically works now. I was able to obtain my transponder. I would suggest periodically checking the npc after realm restart and eventually you can complete this quest and get it.

The GMs and devs alike have no idea what causes this and it sure isn’t that SG quest

1 Like