PTR Character Copy Not Working

Really hoping they fix this. While I know the ptr isn’t supported it would be pointless if people cant test the updated content properly.

1 Like

Same issue here

1 Like

Still broken today.

I’ve been trying it a few times a day the past three days with no luck.

1 Like

Same issue for me, getting very frustrating

1 Like

No luck copying character to PTR, hangs till disconnect

1 Like

Same here. Been trying for several days now :frowning:

1 Like

Been having the same problem.

Just wanted to pop in and let everyone know that we believe we’ve resolved the issue that was preventing players from being able to copy their characters to the WoW Classic PTR. Please feel free to try again now.

Thank you for your reports about this!


Still appears to be broken, thanks


Still not working here.

Still broken.

Nice fix, still broken.

No change. Still sticks on the Copy in progress screen.

still stuck

The button for “Copy Account Data” is now clickable when it was greyed before. However, it says “Copy Failed” for both servers. Trying to copy a single character also still times out, returning you to the login screen.

As of 7:41pm PST, I was able to copy my main character. Trying a second resulted in the same stuck issue as before.

I managed to get my mage on both PTR the split second the blue post went out… I immediately tried to copy my rogue and issues came back

could it be the “que” for copy is overworked? I mean how many people are trying to copy toons at once…? Ya’ll thought SW city lag was bad with head buff but copy lag is worse…

Just started working for me!