Please fix the new mouse issues

The new patch introduced some severe mouse issues during game play that seem to be related to targeting things (enemies/NPCs/portals). The mouse cursor will rubberband/snap back into a defined area for a short time, during which time you’re a sitting duck - not great for push week.

FWIW I’ve seen this floating around, but it doesn’t seem to help me unfortunately

/console rawMouseEnable 0

Here’s the best video example i’ve been able to find:


Going to bump this, because started having the same issues with my razer yesterday, and today. Use my mouse to move my characters, and my characters would also just randomly stop moving while using the mouse. Uninstalled the mouse, and drivers, then reinstalled did not help at all. Also reloading ui did nothing to fix it. Mouse works just fine, or normally out of game btw.


That has a link to follow for updates, since the console command is not working for you, OP.

Best wishes!


I also have this issue, ever since the patch/maintenance this tuesday.

Highly annoying and I thought my brand new mouse suddenly broke.

Hopefully a fix will be available soon.

1 Like

Mouse issues are very annoying. Noticing it during the Shell Game that the mouse doesn’t seem to react like it did before. Also my mouse is randomly zipping across the screen since the patch.

1 Like

Same slow response and clicking seems off.


i didn’t notice, as my Razer Naga has been doing this for over the past year

i don’t participate in the cutting edge content beyond world questing so it hasn’t broken my gameplay

Yeah I’m not having the exact problems others are having, but I have noticed that since the new patch my cursor sometimes gets stuck for a second or 2. I know it’s not the mouse by the way, I tried multiple, including new ones.

I had made a post yesterday saying blizz has broke something with camera. We found a temporary fix for it in which blizz tweeted out the same fix.

Heres the issue… [ /console rawMouseEnable 0 ] will help if when using movement key your mouse also moves the camera at the same time even with no left or right click pressed.

BUT, it also runs the risk of giving you that mouse snap bugg as well… I would consider doing [ /console rawMouseEnable 1] and try and toggle back and forth and see if that fixes anything.

Like blizz tweeted its a temporary fix that may work or worsen, until they fix the real issue. We just waiting for now

Oh, I’m so happy you posted this! I was running visions with a friend earlier and he thought his mouse broke. I’m going to give him a heads up about this since he was talking about ordering a new mouse.

I thought my mouse was finally dying. It’s a relief to find out it’s just more issues with this game.

1 Like

Funny, I was healing some M+'s last night, Disc priest so ofcourse Mouseover macros, so my mouse is usually almost always floating over nameplates. Then all a sudden its on the other side of screen. I just thought I did it lol. Thanx for posting this.

Oh, maybe I wasn’t imagining things.

Try fishing it’s noticeable.

No problems with my Logitech G700s

I tried the “fix” no affect unfortunately. I’m not able to click on interface and when I try to move mouse to make Character look up.

If your using the Atlasloot add on it is also causing mouse interface issues. Mine kept getting stuck unable to click anything. But you have to delete the Atlasloot folder from your tInterface/Add-ons folder in your game files, just disabling it didn’t work.
(Thanks to another poster earlier, he found the issue but I can’t find the post )

i was having that problem too. then i decided to turn off all my add ons and wait until they get updated. fixed my mouse problem. it’s a conflict with add ons it seems.