Not getting Sparks of Life in Zaralek Cavern

Not getting Sparks of Life in Zaralek Cavern – hotfix incoming?


Same here. Only thing awarding sparks of life are pvp kills. I did 3 world quests including the PVP exclusive one, picked up half a dozen treasures, killed 3 rares, and grabbed the supply drop and have a total of 6 sparks of life. All the sparks came from the PVP around the supply drop.


Same issue as for now. Killed some players and got 6 sparks for it. Did the WQ and killed rares but none dropped. Hopefully they fix this soon


Good to hear I wasn’t the only one experiencing the issue.


Same… be sure all to submit a bug report and thanks.


Yeah what is up with this? It’s almost impossible and not fun just being farmed over and over.

1 Like

I sure hope so.

It was almost too good to be true to see that the Sparks quest this week was for ZC.

Same. =/

Only getting them from pvp.

1 Like

The sparks quest tells you to leave ZC via the tunnel. Wonder if this is part of the issue


Why is this not fixed yet?

1 Like

Samesies brah.

Just picked up a crate in ZC. no sparks
or from WQ.
but I did get sparks from killing

I guess I’ll hold up on doing this quest until it gets sorted out

Also why is it 100, when Forbidden Reach was only 50

yeah it still doesn’t work.
perhaps it’s ok, not getting pvp items from pve, but 100 kills is plain silly.

Probably because if it is working as intended, you can just finish it with world quests the first day since there are a lot of world quests + a guaranteed PvP world quest down there. Forbidden reach had really just rares, though it ended up being extremely easy due to the profession rares being soloable.

Hopefully they fix sparks in ZC soon, it’s really dumb that it still isn’t working right. Not everyone wants to get into groups and farm kills for their sparks. The usual methods of air drops, treasures, rares and WQs should also definitely work, so I can’t imagine this is intended.

Is this happening to everyone or just us

Still no fix or blue post yet…? lol…

wowhead is reporting it fixed now

Add me to the list of not working

It’s fixed

1 Like