No Sound in Classic when using launcher

Have sound outside of game and in retail but if using Bnet launcher to start classic I get no sound. Drivers are up to date, device selection in game does not affect it. Any ideas?

Might you have the sounds disabled? This has happened to me a few times. Go into key bindings menu and find your bind for “Toggle Music” Use it and see if it affects your sound…if it does and you want to avoid in future remove the bind so you can’t hit it again.

No sounds not disabled

The only time that happens to me is when I switch from my speakers to headset or headset to speakers as it happens both ways. I have to manually go into the sound settings on the computer and switch to the correct device then go into the sound settings in wow and pick the same device.

Note: Even though it says “default” in wow it still thinks I am not using my headset or speakers, whichever one I am trying to use, so I have to pick them manually then I can switch it back to default.