No Characters found in the Americas and Oceanic region

The app was working fine for awhile. I hadn’t used it in maybe a week or so. Tried logging in, It says “No characters found in the Americas and Oceanic region” no matter what I do. The app doesn’t say it needs an update in the store. I force stopped it, re-logged in multiple times, tried changing region back and forth. It should be finding several characters, but instead it finds none.

Early in SL it could never find characters, then randomly at some point you fixed it, now it seems to be unfixed. I never did anything to make it work last time it was doing this, I just complained about it and randomly it started working again after an update.

Same problem here

I found the same issue. After some time left in that list/error the characters appeared. Try to leave it for a bit

Well, at least this isn’t a unique issue I’m facing, I see it’s happened in the past. I’ve also done all of the suggestions such as uninstalling, reinstalling, clearing cache, hard reset, etc, and still doesn’t work…I’ve never had this before, was working fine yesterday. I wonder if it’s because right now it’s the weekly update? Still, I should be able to use the app. Can’t believe I pay for this game and have to put up with so many tech issues…smh

At this point, the servers may be undergoing scheduled and announced maintenance, so you wouldn’t expect anything to work.

And resurrecting a long-quiet thread for an unrelated issue is poor form.

Resurrecting an old thread is poor form lol? Thank you for your reply.

I am also having the same issue.