Need help with wyrmtongue caches

Hi all,

I’m trying to complete the breaching the tomb achievement. I’m on the “relieved of their valuables” quest to find 3 hidden wyrmtongue caches.

Every location I go to for a cache is empty. I’ve been wandering the broken shores for over 6 hours now and haven’t gotten a single chest. This is highly irritating. I am BEYOND ready to move on but I can’t. I’ve sat in a spot after hearing the respawn timer is 15-20 minutes. I sat in a spot with 4 chests clustered pretty close together and after an hour nothing ever spawned. What am I doing wrong?? This is making me want to pull my hair out. The grind in this game is unbelievable :frowning:

Things i’ve tried;
-Disabling addons
-Relogging
-Emptying all legion quests from my log except the wyrmtongue caches
-Reloading UI a dozen times

Side note, I tried yesterday as well for a couple hours before bed and never found one either

I’m at a complete loss. Any help would be wonderful and i’d be beyond grateful. Thanks.

hmm… I’ve honestly never had that much trouble with them. Without a whole bunch of people there farming them, chances are they won’t respawn very often though (as they’ll be stuck in the locations they already are, there’s no reason for more to spawn).

My normal route when I’m going through that quest is to start on the island off the east coast of Deliverance point and work my way clockwise around the zone from there along the coast. On a bad day I’ve had to circle the Broken Shore twice before it’s completed.

On the chance that it does have something to do with your UI, the steps you’ve already taken might not always be enough to fix the issue. I would recommend a full UI reset as outlined below. Best of luck!