Necro Assault = Epic Blizzard Fail

Sadly, yes. Tried joining a group, relogging, dropping the quest, etc. - always it was the glove/hand that wouldn’t register. Lots of others were having the same issue this morning with me.

I also did post about this in the Bug Report forum, for all the good it will do.

1 Like

I was able to complete it no problem, however I have to say the entire assault was painful and I’ll probably skip it next time…

I believe the 2nd weekly assault happens late Friday so that there is equal time for both assaults per week. I also did not experience any issues (did the quest on 3 toons).

Did it on 3 toons, zero issues. Kevin on the other hand … I need a word with him!

i did not experience this on either character that did the assault. not saying other people didn’t… but it’s not always as simple to pin down a bug as you might think.

this was definitely the most annoying of the assaults, though. stuck in combat after exiting vehicles. weird aggro issues with big packs of elites. etc.


my main didn’t have a problem with the parts tallying up quest progress.

instead, the NPC to turn in the quest was missing for about 10 minutes, didn’t reappear until i noticed someone else dragging their parts over. maw tended to lag spike as i did the assaults, but that might just be my ISP and/or VPN being lousy

Totally appreciate that! What makes this rant worthy (at least to me) is the fact they reported last night that it was fixed…only it isn’t, at least not across the board. The timing of everything makes it so because they didn’t actually fix it in time, some of us lost out on completing it.

Poor planning + not telling people the correct information + no time left = rant

1 Like

Don’t worry boys… They’ll have the Chains of Domination beta ready for release by August if they hurry.

Did the Necrolord assault over the weekend

Didn’t have a problem with Kevin, getting Kyrian parts, saving the souls to make them maldraxxus soldiers, nothing

Kevin ate things like he was supposed to

Yeah, it worked for some of my characters and others were bugged.

Also, I don’t know if this is related but I only had the bug when grouping with others.

Had the hand-dragging problem when I did the invasion. Tried grouping and moving to another phase, but that didn’t help (nor did it help the people I was grouped with). I had to drop and restart the quest, at which point it immediately gave me credit for the hand it wasn’t seeing on the previous run, then had to gather the other two pieces again.

No problems on my end but a friend played late at night when there wasn’t as many players and said it was buggy and unplayable.

The Kevin thing people experience is either a bug or just the way the quest was designed. I would get credit for every other mob that I killed, but some people said he only ate if you landed the killing blow. I just assumed Kevin’s internal meter requires 2-3 mobs before it counts as a glow up.

Some guy claims it took him an hour to complete and I’m just not buying that.

Amusingly enough, I only started the Kevin quest this morning after the hotfix had been applied, and I got credit for every single kill. Took maybe three minutes (if that), so clearly Blizzard knows how to fix stuff…sometimes.

oh, so it was a bug? well good to know they were quick to address the problem. guess I got lucky since there was so many players in the area to help feed.

The only problem I had was waiting on the Mad Maw Construct to spawn and get the last quartered stone ring piece. He would spawn then die instantly before I got the other 3 pieces and had like a 20 min respawn timer. Had to wait that timer out twice.

WoW Hotfixes – Updated July 12 - Community / General Discussion - World of Warcraft Forums (

  • Kevin will now provide credit after eating enemies if he lands the killing blow for “Somebody Feed Kevin.”
  • Dragging centurion pieces to Mikanikos during the quest “Putting A Plan Together” should now be more reliable.

Right…except it still didn’t work, for a lot of people, right up until the maintenance. If it had worked, this post quite literally wouldn’t exist.

I figured it would start working after today’s maintenance.
¯ _(ツ)_/¯

1 Like

Who knows, maybe the Necro Assault will be back later today and we can find out :grinning:

My experience with the Necrolord assault this weekend.

-Stitching quest didn’t reliably give credit
-Kevin would only reliably eat when I deliberately did not use my minion.
-Completing the Construct quest required going to Stormwind, turning on Warmode, and coming back, at which point I immediately got credit for the one piece that wasn’t registering.

All together I spent a couple of hours, and having to log to the forums/wowhead to get tips for the construct quest to get this assault done.

It was one of the first things I was doing after re-activating my account on Saturday and left me frustrated enough that I logged off without completing it Sat night. I came back and finished it Sunday.

Side note: I also ran into a bug with the defeat the Jailer Eye quest where I could pick up the NPC’s spear, but couldn’t use it, nor could I follow her instructions to target the smaller eyes. I just kept hitting the main one until if finally went to the cut-scene.