Nameplate Question

I want to show nameplates ONLY in combat, but it seems to either be entirely ON or OFF.

In Options >> Names, I UNSELECT “Always Show Nameplates”. It says it’s supposed to show nameplates in combat, but I don’t see it at all. If I hit V to show Enemy Nameplates, it just turns on ALL enemy nameplates and there are nameplates everywhere. Is there a way to show only the enemy your are fighting nameplate? I feel like this should be easy to do, and I just can’t figure it out.

Turning off Always Show Nameplates makes it so nameplates only display when you’re in combat but it doesn’t limit it to things you’re in combat with. So you can easily spot things like pats and adds.

I’ve determined the problem is that Quest NPC nameplates are always ON, unless I just turn off all nameplates. Is there no way to turn off Quest Nameplates, too?

You mean NPC Names?

That setting is separate from nameplates.

No, it’s actually the nameplates. It shows Nameplates of NPCs that are part of an active quest. If I kill all the enemies of a quest objective, the nameplates go away.

Does that make sense?

Can’t duplicate it with the default nameplates. The spiders are quest mobs, as indicated by their names being visible.

Or ElvUI’s

1 Like

How can I attach a photo here to show you?

Host it on imgur or whatever and wrap the link in code tags (</> button on the toolbar). You need more reputation before it lets you post actual images like I am.

Okay let’s see if this works:

https://imgur.com/a/5WFZsOY

This is with NO addons. Quest Objective nameplates ON even though Always Show is OFF. I even reset my UI by deleting CACHE, INTERFACE, and WTF folders.

Edit: Also, I submitted a ticket to Blizzard about this, but they told me to go to the forums. I’ve also tried installing Plater, but I still can’t figure out how to hide Quest Objective nameplates.

Ok looks like actual quest mobs vs world quest mobs are handled differently (or maybe it’s an xpac thing but I doubt it)…

Unfortunately, I’m not seeing a CVar to adjust that behavior. So it would appear it’s “working as intended”


Thanks for trying to help!

1 Like