Maw Hunt bugged...AGAIN

These hunts bug more often than they work.
On defeat the Alpha Anima Devourer…and there’s no Alpha Anima Devourer.

25 Likes

+1, spent a solid hour looking around the area for it. No one else on the server can find it either.

2 Likes

same here…cann’t find it at all

1 Like

Yeah, I had to port to Oribos and go back to the Maw to fix the phasing issue. But upon killing the alpha anima devourer I did not receive credit (was in a party of 3, and neither did anyone else). I left, and came back to, the maw… only to have it not spawn at all.

2 Likes

Bump. Still messed up.

1 Like

Literally all four hunt types can bug out like this. It’s pretty silly.

1 Like

Bugged out at the same stage on Whisperwind at 12:09 ET on 12/26. About every other Hunt is broken or stuck. Then there’s the whole broken party phasing issue. This isnt helping improve my view of the Maw.

1 Like

STILL broken on Boulderfist. 3rd time I’ve encountered this.

Bugged on Silvermoon too. What’s the point in even posting though, They can’t even be bothered to take ten seconds to say “We’re aware of this, working on it.”

5 Likes

Same problem on US-Durotan …

+1, WM off, horde, area 52. The chains to bring him down are there, but he’s not around :confused:

2 Likes

Hope Blizzard fixes this crap soon, if you are going to make an obnoxious rep grind in an annoying waste of time zone, at least have the quests work. One week was annoying enough, now it happens again and no hot fix?

Both WM off and on don’t work for me on Arthas Server.

Figure it out. Buncha dingus.

6 Likes

Was it ever fixed?

Guess cutting corners and firing all the QA employees didn’t work out.

1 Like

Broken on Illidan as well on my layer. 3rd hunt in a row I’ve tried to do and has been bugged for a while. Barely got the last one with how long it was bugged…

1 Like

Bugged - Burning Blade

Gated and timed content feels really bad when it is bugged constantly like this.

When i looked at the bug list yesterday it wasn’t even listed as a bug???

It was bugged on Stormrage as soon as 22 minutes after the Hunt swapped over.
Shadehounds seems to be the only one that doesn’t bug out almost instantly.
The Winged Soul hunters, in particular, is a problem since it drops one of the rare Maw-usuable mounts (and the Torghast one isn’t yet available).

So i went back this morning, nothing there, but then when I was doing other stuff I noticed a Teleport had opened to the Beastwarren from behind the Maw vendor (the same one you can use to get to tremaculum so next time I came back to the maw I used that teleporter to come to the beastwarren and the 2 anima devourers had spawned. I realised every time i came over here I was getting a beast and riding over, i wonder if you need to teleport. (nope tried a heap more times couldn’t get them to spawn again)

Didnt you guys know? You played the alpha and now you’re playing the beta.

2 Likes

The Shadehound Hunt drops the mount, the Winged Soul Eaters does not. But it’s still beyond annoying that every hunt bugs out.