[Main Thread] Nvidia - Texture Flicker. Possibly caused by MSAA

My issue started yesterday and I have a video of it I could post. But the issue I am experiencing is all the tree tops and some larger ground plants flickering in Zuldazar.

I went through all the games graphics options 1 by 1, from lowest to highest setting and found the issue to be related to the AA used. Both FXAAs and CMAA resulted in no flicker but all MSAAs incurred the flickers. The lower the MSAA the worse it appeared to be.

My specs are as follows:
Windows 10 Home
1 TB Samsung Evo NVME
Ryzen 3800x
Gigabyte Aorus Elite
EVGA RTX 2070 Super XC
32 GB GSkill DDR4 3200mhz
Corsair RM750x
Kingston 1TB SSD
2 Seagate 1 TB Harddrives

I also have a DXDiag and MSInfo from time of writing this.


I have the 2080 super and had flickering with Nvidia drivers in the series line of 445.xx + Drop back to 442.50 and or 442.59 either is fine and you should be just fine. I am also on the latest windows release and it is performing just fine on it.


Thanks for the report, Dagaria, and for sharing the other thread, Dokkan! We are currently tracking details on the issue with the texture flickering. The main workarounds right now appear to be the following:

  • Switch to DirectX11
  • Disable or try other Anti-aliasing settings. MSAA x4/x8 seems to be the primary culprit.
  • Revert to older drivers, 442.50

What driver version are you on Dagaria? If you’re not sure, could you provide a DxDiag file? Copy and paste the text file created and paste it between two ~~~ like so:

DxDiag Here

If you have issues pasting here, use Pastebin and post the end of the link. (ie. 123456 for pastebin.com/123456)

I just built a new system and at least in my case I disabled Tripled Buffering in Advanced and left MSAA maxed at 8x color and depth. I found a place in Boralus Harbor where it was flickering wildly and starting tweaking settings. When I disabled Triple Buffering the screen froze for a few seconds (thought it crashed) and then the flickering vanished. Running a i7 10700k with a 2080 super.


Thanks for the details, Michellê! I’m getting this added to our tracking. What driver are you currently on? Is it the latest 446.14 drivers?

I am also having this issue ever since installing the 446.14 drivers - even with MSAA turned off.

I did not have any problem of this type until the restart arrived.

It didn’t matter the area or the type of content, the textures just exploded lol

Depending on how the camera was oriented a map could be in the middle of the day or in the middle of the night.

Lights and shadows on objects or characters …
In places where there should be fire there are also squares on the surface below them.

Right now I’m going to stop playing because these textures are making me dizzy.

@ Turack & @ Promenthas, does the suggestions from above seem to help if you haven’t tried all of them yet?

Michellê, also found that disabling Triple Buffering seemed to have helped with the flickering. If this works, please do let me know!

The second option apparently.

I did it from the Nvidia software

@Caterpepi I always run triple buffering disabled - doesn’t help - I will try reverting my drivers later (The 441.XX drivers don’t appear to have the texture flickering issues when I checked last). Also, if it helps the issue I’m seeing is most common with waterfalls (especially the ones in Tirigarde sound).

I had previously fixed it by switching from MSAA 8x to CMAA.
But the problem returned.
And I didn’t make any changes.



In the first image I am trying to kill the dwarf in Stormwind.

In the second I am in Ny’alotha, Hivemind.
Those green rectangles killed me over and over for not giving me a correct view of things.

I never had these problems until last Tuesday’s restart.

Has anyone seen improvements with the driver release from 2 days ago? It should be version 451.48.

For those experiencing the issue, even after disabling MSAA, the most consistent workaround that I’ve seen with this flickering issue is with switching DirectX11 or reverting to the 442.50 drivers.

If none of these suggestions seem to help, please check for any overheating or overclocking within the system.

1 Like

@Caterpepi - I tested with the 451.48 driver and the issue persisted. However, I was finally able to solve it (looks like this solves it on the latest few drivers).

Essentially - I had all forms of AA disabled in WoW - BUT in the nvidia control panel while Antialiasing was set to “Application Controlled” - the Antialiasing - Transparency setting for me was at 8x (Supersample). Turning this setting to “Off” caused the issue to be resolved.

It appears this is what was causing the extreme texture flickering on bushes and waterfalls, etc. At least in my particular case.

I would guess based on the evidence that ANY form of “transparent” antialising being applied in the latest few driver releases is the direct cause of this bug based on this.

Update: I did more testing and even with these new settings I still occasionally see this issue, especially with bushes/trees in stormsong valley.

1 Like

The newest driver added some great quality of life changes overall, but nothing to fix the texture flickering. When I change from “Auto Detect” to my GPU (or vice versa), it fixes the flickering, as well. I’ve changed other settings while the flickering was happening, but nothing had fixed it except for that or closing the program entirely.

I am having issues with the anti-aliasing, as well. Turning on MSAA causes some objects in the world to become “shadows” of themselves.

http s://imgur.com/a/gJZJlQc

Making the game use Directx 11 didn’t fix the problem. I don’t know how to revert my drivers.

I am having this exact same issue. Previously had a RTX 2080, I now have a RTX 3080 in fact bought a whole new PC i9 10900K no OC. I figured maybe changing stuff up would fix the issue but it has not. The only thing that fixes it for me is reverting back to DX 11. With 12 I can run on 10/Ultra settings reverting back to 11 everything becomes clunky this is very annoying as literally every other game I play runs perfectly fine. I wish someone would just fix this already because it is very annoying. I also have MSAA/anti-aliasing completely turned off.

Last two driver updates from nvidia is causing this flickering. I had to update due to cyberpunk can’t revert to old drivers.

rtx 3080/460.89. Switching things on/off seems temp fix it

Hello yeah I noticed this issue as well, lots of flickering on objects… GTX 1080ti. all the items listed to “disable” were already disabled. Changing quality setting helps only a little but it’s still there.

Drivers 460.89 are causing this for sure. I downgraded to 457.30 and I’m having 0 flickering.


Seeing same issue and so far looks like going from directX 12 > directX 11 is doing the trick.

1 Like