[Main Thread] Crashes on launch after maintenance Jan 24th

Same it hurts

1 Like

My Intel iMac is definitely crashing after full cache folder delete, reinstall Battle.NET and full uninstall and reinstall of WoW retail.

On the other hand, my wife’s M1 MacBook Air is working fine. That might be a hint…


Can’t log in either.

all my nonmac friends are in BGs having fun while im crashing all day. Thanks blizzard, u apes.

tried this and it didnt help

Just wanted to let everyone know that we are monitoring the reports and are looking into this. I do not have any workarounds or an ETA on a permanent solution but it is being investigated.

If everyone experiencing the issue can provide the following information that will help:
Make/Model of the system:
OS Version:

That information will be helpful to the investigation.


Same problem crashes after start using Mac OS 11.7.3

Having the same issue - I hope they can fix this!

1 Like

Love all the Blue responses in this thread.
All the attention let’s you know what they really think about their Mac-user base.


Make/Model of the system: iMac (21.5-inch, Late 2013)
Processor: 2.7 GHz Quad-Core Intel Core i5
GPU: Intel Iris Pro 1536 MB
OS Version:10.15.7

lol very old


macOS Big Sur ver 11.7.2
iMac (Retina 5K, 27-inch, 2017)
Processor 3.8 GHz Quad-core Intel Core i5
Memory 8 GB 2400 MHz DDR4
Graphics Radeon Pro 580 8 GB

iMac (Retina 5K, 27-inch, Mid 2015)
Processor: 3.3 GHz Quad-Core Intel Core i5
GPU: AMD Radeon R9 M290 2 GB
OS Version: Big Sur 11.7.3

Misery I guess does really like company as at least I’m not alone.
Catalina 10.15.7. Update sat with 43.5mb remaining for 15 mins but said I could play. After crash battle net app didn’t show anything pending so perhaps it didn’t really finish ???
Odd that PTR crashes now also where it worked before patch went live.
Live is where PTR is

Same nonsense here. Getting various error messages every time I try.
Mac OS Big Sur 11.7.3
iMac (Retina 5K, 27-inch, Late 2014)
3.5 GHz Quad-Core Intel Core i5
16 GB 1600 MHz DDR3
AMD Radeon R9 M290X 2 GB

1 Like

Big Sur v11.7.3
iMac 2017 (maybe this issue will be the excuse I need to upgrade my Mac)
3.8GHz Quad Intel i5
Radeon Pro 580 8GB

1 Like

seems like an “Intel Inside” issue (edit or not, I see an M1 now)

1 Like

Make/Model of the system: Macbook Pro 16" 2021
Processor: Apple M1 Max
GPU: Apple M1 Max
OS Version: Venture 13.1

Macbook pro 2019
2.3GHz 8core intel i9
intel uhd graphics 630 1536 mb

Make/Model of the system: Late 2014 iMac
Processor: 4 GHz Quad-Core Intel Core i7
GPU: AMD Radeon R9M295X 4 GB
OS Version: 11.7.1

Make/Model of the system: msi gs76
Processor : intel I9
GPU : geforce rtx3070
OS Version: win 10