Locked Away quest - Bugged

The quest in Western Plaguelands called “Locked Away” is not working. Upon looting the outhouse key, I am unable to open the outhouse to do the remainder of the quest.



same, got the key three times still nothing

Caused by bugged layer, i had to swap layer and then it worked.


still bugged, on multiple layers even.

Broken quest. Sweet waste of time!

Still bugged :frowning:

This quest continues to be bugged. Interacting with the diary again changes nothing. Deleting then reacquiring the key does nothing. The outhouse cannot be interacted with under any circumstance I have yet found.

bugged out for me too, diary doesnt give a quest, i picked up the key anyway and couldnt interact with the outhouse
tried swapping layers and still same problem

This is still bugged. I have sent a bug report in. Changing layers did not help.

Still bugged

1 Like

This is still bugged. I only have one layer on my server so… FIX IT.

It was bugged for me for same layer. My friend invited me to the other layer and I was able to click on the outhouse. Blizzard needs to fix this issue for the same layer.

Yes this is bugged tried multiple times.

Still bugged… I submitted a bug report. I hope it gets fixed soon.

Still Bugged.

This quest bugged for me last week. Couldn’t click on the outhouse. Then when they did the maintenance on Tuesday, I can now click on the outhouse

Add me to the list of people trying to do this quest and unable to do so.

Quite frustrating honestly as it’s a high-level quest, where exp is really needed.

Quest bugged 4 me 2 plz fix it

Bugged still… but let’s be patient everyone, they have only had 15 years to fix this… what do you want? everything?

1 Like

Bugged for me, i was able to do that on other characters without any issue, but not on the latest.