Linux users unable to log in, WOW51900328/329 error after logging in

Woot… Good find, TTL change… Thanks… I’m in.

MVP of the night right here <3

Worked perfectly, I will send a few gold your way when I get past the queue :bowing_man:

Was watching “The man in the high castle” season 1, and now it’s gone back to the queue, you beautiful bastard!!

also note the “missing” blue post here, at least to make it no so effing obvious.

You are an absolute wizard.

Pray Bliz doesn’t block this as well…

Oh it WORKS!! Such a good find!! Thanks so much Poolstool. I would not have thought of adjusting the TTL.

Same problem here on Arch running wine-staging 4.15 until I came across the ip_default_ttl solution in this thread. Thanks guys, awesome work!

I really hope Blizzard is going to put a proper fix in place that doesn’t just lock out all Linux users in such a sledgehammer approach, though, before it stops working…

Damn, there’s some true heroes in this thread. IPv6 did nothing but the TTL fix definitely worked


Just throwing in another report of being unable to connect. Tried the IPv6 option to no avail (probably because my ISP doesn’t provide it), but changing the default TTL value to 128 worked perfectly.

how do u change TTL value?

Bumping TTL to 128 fixed it for me too.
You have made my day, or more so night by now.

To keep things tidy and not erased by system updates, I recommend putting the line in /etc/sysctl.d/11-warcraft.conf. That way you’ll remember why it’s there 6 months from now and it’s less likely to be overwritten.

1 Like

@Blizzard: Give this guy a free lifetime subscription.

1 Like

Yes, it isn’t linux in particular.

OpenSuse here, since the Burning Crusade expansion when I deleted my Windows partition.

Currently OpenSuse 15.

Can’t log into Baegun.

Stop reinstalling Wow/changing prefix in wine/whatever:

It is the DDoS attack, not a linux/wine problem.

Windows people are having the same issue.

I Logged in fine Sunday, but could not leave Mechagon (hang at hearthing screen, to borealus or Dalaran “Transfer aborted: No such Zone.” ) So it was “fun in Mechagon day”, on Sunday!

echo 128 > /proc/sys/net/ipv4/ip_default_ttl

Got me in instantly!!! Thanks!

sudo it did not work(permission denied), had to su in bash, then pasted it and it worked.

1 Like

For lost windows users

cant even login to battlenet or their website :confused:

Just adding info that changing default ttl didn’t fix anything sadly.

Glad for people that did but its not a foolproof fix. On the meantime I unsubbed, a whole weekend where I can’t enjoy a service I paid for (even if it translates to 50c, I still pay for it) and I get to watch streamers play with no issues. Then a moment of hope! I get to enjoy a queue I wait patiently til I see my character select screen only to be met with the error once more

This morning? Still no service
That’s 3 days of non service now. If I can’t enjoy the service I paid for for why should I keep paying? I’ll think about resubbing at the very last minute if its worth it. But right now even with all the hype, it isn’t

Hope everything gets fixed as soon as possible


Linux Mint 19, Spectrum ISP, using Lutris. I can’t connect to Classic or Retail but the Windows PC on the desk next to me on the same connection is playing just fine. I did all the usual troubleshooting and got nowhere. It seems like it is indeed just my choice in OS. :confused:

Edit: This echo 128 > /proc/sys/net/ipv4/ip_default_ttl trick worked for me too. Like above, sudo alone wasn’t enough so go full su. At least I can play. (Can someone link me to why this works though? I’m interested!)

worked for me too =D

Well the sudo sysctl net.ipv4.ip_default_ttl=128 worked for me. I first just tried to log in normal. Same as its been for the last almost 24 hours. I then executed the above command and got right in. I am not a super linux user just getting back into it actually. What is a step by step easy way to make this change permanent so I don’t ahve to deal with it again? I am using Lutris on Pop OS