Legion: Stuck on The Sword of Kings (Warrior)

I’m at the point where I need to kill Zakajz permanently. I have the sword equipped and… nothing. There’s no pop-up attack for it, there does not appear to be an extra attack for the sword to work. I’m not sure what I’m missing here, but I am unable to complete this artifact quest at this point.


just press F4 near the dead Zakajz

Thanks for the reply! I went to do it again and started the whole thing over and then the button for the attack popped up so I did not get to try F4, but if a situation like it pops up again I will try it!

Well for one, pressing F4 doesn’t do anything on its own, he was just trolling by trying to get you to close your game with the shortcut Alt + F4, and failed miserably…as for this issue as well as others like it, just type /reload in the chat box to reload the UI ingame. I just hopped over here cause I had the same problem. Tried the reload command and it worked.


This worked @Necrolith. Thank you!

1 Like

No problem @Dedriana, happy to help.