Lag/Jittering with every quest hand-in/Level up


#7

Same problem here. Addons aren’t the issue.


#8

same base UI, even reset my WTF folder.


#9

I too am having this issue. It’s not game breaking, however it’s annoying and just started with the patch.


#10

I too am having the issue. I noticed I had a GeForce game ready update for my card, did that and it’s still no different. Was questing my butt off just before the patch for Mag’har rep before this without a single issue. Now it’s every single time I level up or turn in quests.


#11

I also did a driver update to see if it would fix it. No fix, still lagging and now I have a new driver… Would trade that for the lag fix.


(Caterpepi) #12

Thank you for reporting this issue over to us! We are seeing a handful of these reports. Could those experiencing the issue see if some of the basic steps may help? Some of you may have already ran through all of these steps, but let us know if it helps!

If it continues, can the following be provided?
[Edited] - Details no longer required, please check the next blue posts available


#13

Ran it from a clean reboot, updated GPU drivers (Win already up to date) with zero mods (deleted Cache, WTF and Interface) still lags to all heck when completing quests / WQ / Accessing items in the wild such as chests.


#14

I’ve done all of the listed steps. Including a fresh GPU update this afternoon, still happens. And didn’t happen as of yesterday before the patch.

I’m on Emerald Dream, NA. My timezone matches to my realm also. I don’t need to monitor exactly when the lag happens, because I can tell you exactly when it does. The game runs silky smooth until I turn in a quest, finish a world quest, level up, or interact with an item in the world, like treasure chests, etc.


(Clinkz) #15

Happening to me also, and it started with 8.2.5


#16

Having the same issue, but I think it’s more a 1-2 second freeze than just lag. It happens randomly at times, but mainly when things like a world quest dialog box comes up, or when you’re on a quest to kill a specific number of mobs - each time the tracker shows you kill one it will happen.

It is more an annoyance than anything, so hopefully it’s fixed soon.

*edit - as the others have mentioned, it just started with todays patch.


#17

I think you’re absolutely right. It’s not even lag, and my FPS seems to still stay at a smooth 60fps even when it’s happening. So a slight freeze is a much better description.


(Caterpepi) #18

Thanks for providing further details, everyone! - I should have been more clear, I was looking to see if this is happening in specific zones in World of WarCraft.

I have some suspicions this is related to an issue that we’ve seen in the past. If this in a BFA zone, does enabling Warmode seem to help a little bit? This was a hit or miss in the past, but may temporarily workaround the issue.


#19

Ok I am doing WoD and getting this issue. I am also running the game off my HDD. Everytime my screen lags my HDD (which is loud) makes this noise like it is trying to load something.


#20

I’ve had it happen in Dustvar while doing world quests, but also on my level 30ish mage in Ashenvale. My most recent tests to see if it’s been fixed after trying things have been on the mage, because it’s easier to turn something in and find out. War Mode was turned off in all cases, so I guess that could be the issue. I don’t know, really.


#21

I only played in BFA, occurred in every zone I was in. (all but Mecha) Was not in Warmode. Did the World raid boss and it lagged close to 5 seconds while it doled out the drops to everyone.


#22

I’ve tested turning in quests on an alt in WoD introductory content, and an alt in STV, as well as current BfA world quests. All have the same full stop hitch for a second after a turn in.

Tried turning on War Mode on my warrior and completed a quest in Tiragarde, same issue.


#23

I haven’t tried anything outside of BFA zones so far (horde emissary in Zuldazar, alliance in Tiragarde Sound, Nazjatar for the weekly world boss). I don’t play with warmode on.


#24

It’s happening to me as well and I just started a fresh character. A dwarf hunter. It was doing it in the starting zone and is now/still happening in Dun Murogh so it’s not related to any specific areas. I have also had it happen once in a great while (very rare but it has happend) when I loot something. Otherwise it’s the same as others have said.


#25

Exact same issue, game was perfectly smooth before the patch. Running no addons, reset settings, cleared cache/wtf folders. Game just freezes for 1 second whenever completing a WQ. (Ping/Connection is fine)

1060 3gb, i5 8400, 8gb RAM


#26

I don’t think it has anything to do with what zone you are in or warmode. Game will dip from 60fps to 40ish and freeze with every quest turn in and lvl up. Happened to me in starter areas STV Outland and DK starter area so far. Everything was perfect before patch nothing has changed on my end.