King of the Foulweald. Shadowlands Bug

New to Shadowlands, the quest King of the Foulweald in Ashenvale never ends. The furbolgs keep spawning and attacking, but the boss, Chief Murgut never spawns. In fact, the regular furbolgs never stop spawning, long after the banner has despawned.

15 Likes

Happening over here too.

Same issue. Tried with a level 29 and level 50. Reported the bug in-game.

Seeing this bug as well

I’ve also had this issue.

Having this problem as well… any updates?

Can confirm that this is still happening. Just tried to do the quest

As of 10/30/2020 can confirm it is still bugged and furbolgs still keep spawning and attacking without the Chief ever spawning. Banner eventually despawns and furbolgs will keep attempting to destroy the banner.

14 days ago and still bugged, plz i want my mog blizz

found a way around it where you let the first mob start the cast to destroy the banner, interupt it and drag it away from the mound until the boss spawns and you should be all good

8 Likes

I’m experiencing this bug as well, attempting the quest now (11/2/2020) and the adds just keep coming.

Works. ty :slight_smile:

Trying to do loremaster. as of 6/11/2020 it’s still bugged. Furbolgs endlessly spawn without the king coming.

Still bugged 11/12

I was just able to overcome the bug for this quest after trying for a few days. I took the advice above and let the first mob begin attacking the banner (for me it was actually the second mob because I had accidentally pulled the first). Then I just let him whack me for a bit while I just stood there healing. After about 3 or so minutes the Chief spawned and I was able to kill him. I noticed that the time it was successful my flag did not despawn as it commonly has done. So if your flag disappears just let the mob destroy the invisible flag and try again. Hope this helps someone :smiley:

2 Likes

I can confirm this doesn’t always work. I have tried this workaround several times now and the Chief never spawned. The flag despawns in less than a minute for me so I never get to that “around 3 minute” mark.

EDIT: I got it to work. If you are high enough level that the Enraged Foulweald’s can’t hurt you, DO NOT just stand there. I think if you just stand there and take without doing anything the game will end the quest. I ended up casting non-damaging spells repeatedly which seemed to keep the banner from despawning. After a minute or two the Chief spawned in.

tl;dr- While taking damage from the Enraged Foulweald, make sure you are casting non-damaging spells.

2 Likes

11/16/20 still bugged. Took 8 attempts at 50. Worked when I let one beat on me till Lightning Shield killed him, casting Healing Surge. Windfury, & Flametongue. Second came, got his aggro via running then killed. Third came with boss.

Fix this shizz Blizzard

Bugged for me, too. Please fix!

can confirm, almost a month on, this bug has still not been fixed

still bugged