Karsh Steelbender bug in Blackrock Caverns

outta curiosity how much aoe dmg does the stacks do compare to back in cata ? use to be able to leave him up to 8 stack back then b4 being force to take him out…once it went pass 35% per pulse it was too dangerous to leave him in there for a long time…and that’s with having a god tier healer and tank…fully aware things change since but haven’t run that place in forever…dont seem to be part of timewalking either…Hall of Orgination and Blackrock Cavern never popped for me despite being strictly cata dungeons during timewalking otherwise I would of had a better idea of how much dmg goes out now

there a chiev for 15 stacks…would be surprise that the pulse be stronger than b4 but ya…if pulse dmg is bout same % as b4 straight to 8 should be possible…that said…a bug like that cant be good…would not want to spend an eternity killing a boss when I work on my new char for heritage armors

My DF runs are still falling apart over this in mid March, whoo.


I just did him today. He’s still very much bugged. Kind of ridiculous that something like this has been bugged for months with no fix. Good ole blizzard.
Can only keep him in for 3 stacks. 4 Stacks and he’ll wipe the group. Not long enough to get him down.
Side note, he should be skippable from what I can tell. But my group all left in frustration as did I after 4 attempts.

1 Like

In here now and it’s bugged

1 Like

My group just got to this dungeon today (April 12, 2020) via group finder and we ran into this same bug.

Tank had him standing in the middle for forever and nothing happened. We even completely cleared the room and nothing changed.

Decided to reset (die) and try again and got the same result. The fire in the center did absolutely nothing and we wound up giving up and breaking off the group.

Members were:

Still bugged

I’ve run into this issue in 2 seperate groups today on my unholy dk, and I think I know the specific issue.

I’ve found in my details damage that I was hitting something called “Invisible Stalker (Hostile. Ignore Combat. Float. Uninteractible, Large AOI)” with my Virulent Plague, which is a damage over time ability that naturally spreads from whatever target I apply it to with Outbreak (in this case I was targetting the boss while he stood next to the pillar).

The very next pull after I figured that out, I stopped using Outbreak and the boss worked as intended.

So I hypothesize everybody else who runs into this bug has an unholy dk in their group that hit this entity with Virulent Plague, or there are other abilities which hit this invisible entity that is either killing it or stopping it from triggering the lava pillar from running the boss through it.

IF YOU RUN INTO THIS BUG and you have details damage meter or another damage meter addon with specifics on targets hit, see who’s hitting that entity (“Invisible Stalker…”) and with what ability and tell that person to stop using that ability until after you kill the boss.


This absolutely worked! Thank you so much! My group was so frustrated.

1 Like

Seriously, no fix yet? Wtf?

Well now I feel bad for causing the bug and the party to fall apart. Still… blizz should fix this issue.

Same issue 5/8. The super annoying thing? He’s on my run of solo dungeon clears with an Unholy DK. Trying the run and avoiding Virulent Plague, let’s see if that fixes it.

EDIT: That 100% did it. I didn’t start the fight with Virluent Plague, debuff stacks went on him just fine. Thanks Coconut!!

Just happened today but I got into another group and he wasn’t bugged. Seems to be random.

Bugged still, after death/reset the debuff started applying immediately after being pulled, unable to stack the debuff at all.

I had this happen today and found this thread. Our DK was damaging invisible stalker. We got him to stop and then stacks started to get applied.

We got boss to 2 stacks and pulled him out to dps. At the second round of stacks, most people instantly died from the damage. We then had one dps switch to heals and set up a CD rotation, but even then 2 stacks seemed to be too much. This boss seems to be a little overtuned for a leveling dungeon.

I just checked the log and our UH DK was hitting something like an Invisible Stalker with his Virulent Plague. We already disbanded the group and left before I started Googling this problem. I ran into this with my other 2 DK tanks in past. Can’t remember if I had an UH DK in the group or not though.

Same as of today, 06/17/20…unholy dk in grp bugged it

Blizzard, this bug is still around. I ran into same issue today. We wiped three times on the boss on my unholy Death Knight because he wouldn’t get the debuff from the magma. I finally searched for and found this thread and Coconut’s response.

I switched to Frost Death Knight and we cleared it the fourth time like normal. Please fix.

Still bugged. Group ended up falling out b/c of it.

Sorry guys, I didn’t know.

I encountered this bug today in a LFG run on an alt, found this thread googling after four wipes due to the debuff not being cleared. Sure enough, we had an unholy DK in the group. We asked him to modify his rotation, but he left the party instead of doing so… and the boss was fine on the next attempt, so pretty much can confirm this bug still exists and is still caused by Unholy abilities.

Confirmed that this bug still exists with an Unholy DK using outbreak, and does not exist if DK does not use Outbreak.