Iskaaran Fishing Net

At present the quest cannot be completed - when holding all 5 reagents you get the message ‘Missing Reagent - Strong Sea Kelp’ whilst asking Tavio to craft.


This is a recurring issue with different crafting. Recrafting is having similar issues reporting missing reagents.

I have the regents, but when I click Craft all it does is highlight my mouse cursor (pointing hand) as if I am supposed to click on something… Yea… BUGGED…


Same for me trash game since launch

I can’t complete this quest. I can’t even find a 3rd kelp. There were several popping up on my mini map but when I grabbed the 2nd, the rest vanished and not I can’t find any. I have left and came back several times to the area, run dungeons, reloaded ui, and logged out and back in still nothing.

I am also experiencing the same issue. If anyone has any insight on a fix it would be appreciated

Following up, this seems to have fixed it for me:
It seems that I had already picked up 3 but only 2 registered for the quest objective. I went to Tavio, the questgiver, and crafted the net with the reagents I had picked up, which included 3 kelp. Once it was crafted, the reagents were lootable for me again, so I was able to collect all of them and craft the net to complete the quest.

Hope this also helps for you.

Same issue as the rest; please fix.

Getting the same thing.
Just unlocked the harpoon and was able to craft that fine, but the net is still having this behaviour :frowning:

1 Like

Tested again today and still not fixed… Yea think Blizz was make a post or something about it.

I ran into this and was able to fix it by dropping the quest and picking it up again. That made the seaweeds visible again and I was able to get the 3rd one.

Just tried that as well. Deleted items from inventory, went and got the quest again. Then went and got items again, but still bugs out… Pointer hand just turns grey and highlighted.

If you have any Artisan Mastery quests in your log when trying to make this net, it will bug it out. Drop the artisan quests (you can pick them back up) and then craft the net.

1 Like

I will try that soon as I log in. I do not think I do, but I may have one of the quest.

I am still amazed that Blizz hasnt fixed this quest yet… At this point if it Vhaggar’s suggestion doesnt work I am going to put in a ticket and suggest everyone else do the same.

OK, so removing ALL quest from the log didnt help. I only had 2 dungeon quest anyway. So I put in a Ticket… I suggest everyone else do the same at this point.

OK, finally got it to work. When you click on Tavio to open the quest, the crafting menu pops up. CLOSE the Quest Dialog so you can see Tavio and CLICK on Tavio… It then let me create the Fishing Net… Personal note this is so stupid and should not have made it past beta, but I digress. Hopefully this helps others.

1 Like

Glad you were able to find a workable solution for yourself. Hopefully it will help others that may find themselves in this situation. Glad there is more than one possible fix. It’s amazing how many bugs are in the live version. They did not test this enough at all.

1 Like

I abandoned the quest and then picked it back up and it said I had all the items needed, even though it said I was 1 short when I abandoned it. Crafted the net just by talking to him after turning it in. Weird bug but glad that worked. Having a hard time getting rep for Iskaar.

Do the community feast event as many times as you can. Occurs every 3.5hrs. You get 25 rep from most of the tasks the cook gives. Adds up fast. Also, do each fishing daily. You unlock additional ones at each new fishing hole location. Also, the rares that spawn at Brackenhollow give iskaara rep each daily kill. Im at Renown 15 almost 16 with them.

When trying to craft the net it was only highlighting my cursor. The solution was to click craft then when my cursor was highlighted click on my character.


still happening as of today…

There it is! This was the answer! Seems a weird thing to have to do while crafting, but this comment needs bumped. Praises to you my friend! Walk in the light!