I Can't Equip Arrows Since Patch

Title pretty much says it all. I can’t equip arrows in my arrow slot or move them out of the arrow slot. I restarted the game with no addons and that did nothing to fix the problem. The other hunter in my guild doesn’t have this problem. The only thing that I can think of that has changed is that I crafted and equipped the new quiver and that the patch was released. Whatever is causing this problem is related to either the patch or the quiver.


Had this issue myself. I did find that it did take if I dragged the arrows to my ranged weapon in my character sheet, instead of the ammo slot. I wasn’t using the new quiver at all, but at least it did finally take when I tried it that way instead. Might be worth a shot in the meantime.


Right click the arrows from your inventory. I’m not sure if this is intended but this was happening on the PTR. Nothing I did worked except for right clicking the arrows in my bags to get them in to the arrow slot


Thanks for the help. Both methods worked for me. I appreciate it. I was stuck using command console macros and my bars are cluttered enough as it is.

Blizzard took servers down today for hours doing updates and this is happening again. Right clicking on the arrow is the only thing that worked for me. Thanks!

1 Like

thanks tons! this worked for me. apparently we now load the wotlk arrows (and probably other ranged consumables) directly to the weapon rather than the ammo box.

This just happened to me. Crazy that this bug still exists. Anyways dragging the arrows directly onto my xbow worked thx.