Heart of darkness broken?

Azerite trait will not give me the bonus stats it’s supposed to. I’m sitting at 35 corruption and it’s just not activating in or out of combat. Tried relogging, respecing removing and adding all my corruption back and nothing will make it activate.

I’m not sure how you expect this to work differently from other similar Azerite Traits that apply stat buffs. This applies outside of combat as I’m watching my stats window while I reforge my Azerite Armor.
Sitting at 30 Corruption after Resistance, I have 3 Hearts of Darkness traits myself and seeing how my stats appear during reforging seems as though it works as it should. Without any HoD my Mastery sits at 57%, 59% with 1, and 63% with all 3; 66% if I include a Blood Siphon.

I’m guessing that OP isn’t looking at their TOTAL corruption.


That highlighted number is the one that has to be above 25, in order to benefit from heart of darkness.

I’m sitting at 35 corruption AFTER resistance so you did guess wrong.

When you equip a piece with heart of darkness, you need to wait a few seconds for the stats to change. I noticed this on my demon hunter earlier. It takes around three seconds to change.

1 Like

Mine is not working either, with 28 corruption and even at 68 corruption. tried logging in and out, exiting game and nothing.