Guild Achievements not working

Guild Rated Argh is not registering any guild achievements or progression at all. Bought tabard, guild bank tab 7 and not getting any credit for any activity including dailies etc. Customer support had 0 response.

4 Likes

all guild achievements seems to be bugged right now. from crittergeddon, killed a critter and number didn’t change to “That’s a lot of Bait”, was raising the legion fishing pole on Ghost queenfish (the fish near where if you use the portal to legion content) pools and number didn’t go up either when i fished.
so yeah it appears none of them are working right now.

2 Likes

Bump.

" please be advised that this issue is currently being investigated and we don’t have a workaround here, submitting a bug report will be the best solution" - GM lahsinsuih

Typical jerk around response

edit: GM Response received May 21

1 Like

Yep no guild achievements working, submitted a bug about classy achieves not working, got a response saying that its been upped to level 80… but then why do no other achievements work either?

Hoping this doesn’t get ignored since most people/guilds probably already have these achievements :\

2 Likes

Same problem. My human hunter was the last human to reach 70 today (5/24/24) and it didn’t complete the classy human achievement for the guild.

Also not counting Fangs of the Father or Val’anyr, Hammer of Ancient Kings guild achievements, thus also making The Ultimate Collection unobtainable (last two for us). Both wielders are exalted with guild. It seems guild achievements were working at least as of 3/26/24.

Went searching in case anyone else has reported this specific issue and just sounds like all guild achivements are broken.

I found this information on the Blizzard Support site at least regarding the Classy achievements "During a pre-patch, the max level is increased but cannot be attained until the full release of the expansion. Guilds will be able to complete these achievements once the new expansion’s content is released.

As this works as intended, Customer Support will not manually complete guild achievements." https://us.battle.net/support/en/article/358859

Stay classy not working during the last season of an expansion, is a joke. Also, the pre-patch for War Within has not dropped yet…

Better Leveling Through Chemistry, still broken.

Edit: What the Stay Classy increase tells me is they deliberately upped the Stay Classy to 80 so no one could benefit off the MoP Remix event.

2 Likes

see that sort of knee jerk reaction from them is annoying considering they keep moving the goal post each time they add a new class to a race. Leave it like it was with the initial classes and we wouldn’t be using mop remix to try to get the darn achievement. It is a bank vault, no skin off their noses to just award it.

1 Like

I get the feeling we won’t get a response about guild achievements until prepatch at least at this rate. Would love to be wrong though.

Crazy how many posts get made about them and people get ticket responses like “We have no reports of guild achievements being bugged, have you tried resetting your router?”

Bump.

Still not resolved.

Disenchanted a few items and the progress for Dust, Dust and More Dust did not increase. Have a feeling that the Classy achievements are just broken like the rest of the guild achievements, rather than Classy achievements requiring level 80.

1 Like

That was my thought as well. I tried killing some critters, disenchanting some items, doing quests, making glyphs, nothing updated.