Greymane's Gambit

DC'd during Greymane's Gambit. Logged back in and the boat was in SW. When I select Sail to Stormhiem, it loads for a moment then kicks me back to SW.

I deleted the Cache and now it just dc's me everytime I try to log in with that character.
I am currently stuck on this - yet , I never DCd - it just seems like the quest is bugged on "Greymanes Quest Complete: 0/1" - when you talk to the girl to set sail! it does multiple boots, but you eventually just get back to square one.
For those wondering, This is a intro quest chain to Stormheim - I recommend new players or players working on Loremaster to avoid this for now til fix.
Seems like deleting my cache fixed the issue - still, players shouldnt have to be deleting files to be completing quests xD
The easiest way to get passed it was to hit escape as soon as the cutscene starts
2 Likes
This happened to me today. It will not load the scenario after accepting Greyman's Gambit. I just end up in Stormwind every time. I even deleted cache.
How is this still a thing since launch... Can't get past it.
1 Like
Was broken a couple of weeks ago and dropping group seemed to fix the issue. Doing it on another toon today, not in a group, and still broken. Talk to Genn, get the short cut scene, then a loading screen, then a *second* loading screen, and right back in SW Harbor.

Dropped quest, picked it back up, same result.

Tried the suggestion above of exiting the cutscene, but still no luck - back in SW Harbor.
I'm stuck here as well now!!!!
Same here. Did it twice on two other alts, ZERO problems. Today, stuck in SW.

Okay after clearing cache, it worked, but still, WTF? NO problem with two other alts who ran though the zone.
I am currently having this issue as well. Any fixes?
I just had this issue. Accepting the quest showed me the cutscene but ported me back to Stormwind Harbor. Talking to Rogers (I think it was) allowed me to Set Sail for Stormheim again. Took 2 or 3 tries for that to work.

I just thought it was the event thing was in the middle of starting over, so I didn't report it at first. Came to this forum to report something else, actually.
Fix this crap. We should'nt be repeating the bug this long after launch.
Just bumping this, as it is still bugged. Loading screen is the same as the ones from the alpha testing, nothing on skyship when it finally loads, then it puts you back in Stormwind at the quest giver. You can talk to the Captain to attempt the scenario again, but it takes a few attempts (5 or 6) to finally get everything spawned to start the scenario. It was like it in the alpha, the beta, and now STILL in live, well after launch. Please fix this bug.
This is still happening. I just had it happen to me.
Still ghetto and broke
Just had this happen on one of my alliance alts. Talked to Rogers, went through the scenario load screen, which was immediately followed by the EK load screen, and I was back in Stormwind Harbor. The third time I tried to start the scenario, I got disconnected.

You would think, after so many years of this being an issue, that it would have been fixed by now.

Trying to level another alt today, SAME bug.

Same bug with new toon. Can’t get pass the booting

I just resubscribed and am playing through the Legion content I missed while on my 4-year hiatus. This bug is still here, over three years after the expansion launched. Come on, devs. Be better.

WoW Blizz, big fail. I have done everything that those above had said to do and nothing. I wanted to do this zone from Alliance perspective but you guys once again drop the ball. I tried going around the quest but can’t. Fail. GG on responding to the many people over the past few years who have reported this bug and you haven’t answered or done anything about it.