Found out I have beta, but can't post in the beta forums?

So I just got home and I’m over here in a bit of a strange spot/between a rock and a hard place:

  • I can’t play Classic because insane queue times to log in ( :roll_eyes: :-1: )
  • don’t really feel like playing retail since nothing to do/stale

Took a quick peek at the Benediction queue and just closed the game out of frustration.

Then when I was mousing over the little “dropdown menu” on the launcher I happened to notice Dragonflight beta listed there, I’m thinking to myself “great, something to do”

Tabbed out and checked my email box, nothing there - no Blizzard emails, no “welcome to beta!” email, nothing. Then came over here to these forums to see if I could now participate in some of the class feedback threads or maybe ask questions on the beta forum, but the forum buttons to post replies and start new threads are “greyed out” as if I don’t have beta

How do I fix this? Already tried logging out of forums and re-logging in, but still unable to reply to threads or create new posts over there

I don’t think it’s a fluke or mistake, I’m literally in the beta on the Dragon Isles in the background (on the beta), so I’m fairly sure I do actually have beta access since I’m currently messing around ingame with DF stuff as I write this

There are some free transfers off of Benediction that you can always take advantage of so that you no longer have a queue :wink:

Usually re-logging does the trick. It’s possible that since the beta just released, that there may be a delay in new additions to that particular forum too. I’d give it a little time, even 24 hours or so, and try logging out and back into the forums again.


It looks like this was a fairly recent flagging, so you might still receive an email with a notification. It is generally difficult for them to time flagging thousands of accounts at the exact same time as the same number of receives the email letting them know. :slight_smile:

As for access to the forum, the flagging might not have gone through just yet, but can you try logging out and back into the forums again to check if that updates your status?

I know you did it once, but I want to make sure nothing recent changed your status. Maybe try private/incognito mode on your browser to ensure no old cookies cause an issue.


Congrats, I was hoping to get into Alpha or Beta myself but didn’t which is sad as I’ve really nothing to do I just entered hospice care and hoping I get to see the game go live, but do to health issues I very likely might not. So living vicariously through a bunch of streams I guess it’s not the same but it’s all I got.

1 Like

Oh wow, this actually worked :+1:

I logged out of the forums one more time, both on my PC and my phone (so “completely” logged out everywhere), then re-logged into the forums on an “Incognito” tab… lo and behold the “New Post” button is now unlocked and I can reply to threads

So I assume it was some sort of issue with saved website settings/browser cookies, because all of a sudden the beta forums work. We’re off to the races :partying_face:


I’m in the same boat with access to beta but can’t post on the forums. I’ll try the forums later.

Same boat as well.

Same boat as well for me. Was there ever a fix or is this just a wait and it will happen eventually kind of situation?

More of a ‘just give it time’ sorta thing. Be sure to try logging out of the forums and back in again too :wink:


This is what seemed to work for me:

So basically try logging out of the forums “everywhere” (PC, laptop, phone, burner phone, tablet, etc), and then log back into the forums in an incognito tab

1 Like