Extreme freezing and performance issues in Sepulcher

this is my dxdiag the pastebin link in my prev post

Update from my end:

Cleaning my case (to improve GPU temps) and moving the WoW install to the C drive didn’t resolve the issue. My GPU temps did improve by a degree or two, but it’s still in the 75-80 range, which should be perfectly acceptable for an Nvidia card.

So, I tried to remove the graphics driver again, but this time I used the DDU (Display Driver Uninstaller) tool to fully remove the driver and reinstall the latest from Nvidia. Much to my surprise…so far this has worked. I’ve been able to play for longer periods without a freeze thus far. I did dailies last night and this morning along with a couple bosses in LFR as test cases. Tonight I have raid with my guild, so we’ll see if it holds. If it does, then the issue is either resolved or at least back to a manageable level.

To comment on Karsh’s experience. Removing my addons, uninstalling and reinstalling, and moving the install were all unsuccessful for me, and in fact made my issue much worse to the point where I could no longer log in to a character without forcing DirectX 11. Also, after looking at your dxdiag Karsh, we both have a GeForce GTX 1070 card, which could be a common element to the issue, possibly.

Thank you! I will try what you did tonight, and update here if it works

I used DDU and completely removed all my nvidia drivers/programs. re installed fresh.

I just did all my dailies and world quests in ZM and no crashes at all. I dont have time to do LFR right now to test the raid, and my next guild raid night is sunday. I will try LFR and hopefully a key later tonight. Thank you so much this seems to have done the trick!

Seems to be fixed. I ran a full lfr with no issues and killed rares in zm for over an hour, no crashes

Yay! I’m glad that worked for you and that things are better. :slight_smile: I ran my raid and quests today, no issues. So I’m about 90% sure it’s solved for the moment. :slight_smile:

I’ve been having this issue for at least two days. I wanted to give my input that uninstalling and reinstalling the drivers work for me, too.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.