Dragon Flying Making Some Players Sick

The flying is to fast at top speed Im not the only one feeling sick Devs need to look at that aspect.

I have had to log off several times to just make myself feel better I dont know a game shouldnt make you feel sick and thats what this dragon riding is doing to some people.

I thought it was me at first but ive seen several reporting the same exact issue.


part of the reason I am gonna avoid messing with it…I am worried it will do the same for me.
sorry it did that to you tho…

Which section is making you feel sick? Is it the twisting / turning or the side effects on the side of the screen?

I remember a setting a person can change to help with motion sickness but I forget where it is.

They did recently introduce some motion sickness options that might help.

I thought there was something else more recent as well but I need to find it.

More for motion issues that is more recent

And here we go - the Dragonflight accessibility options menu stuffs. That has the most up to date motion sickness helpers in it.


Thanks will try tomorrow not feeling good atm

Thanks for the help


I hope some rest makes you feel better!

I play WoW and Diablo game because first person style games make me very motion sick.

So far I have been ok with flying, but I take it slower and keep the camera zoomed out. I am not sure how I might do with those flight races and stuff.

For basic mobility you should be ok, esp with some of the options turned on and the camera pulled all the way out.

Fingers crossed!


The expansion is wonderful this really bummed me out.

I’m going to turn on the motion sickness controls and zoom out tomorrow fingers are crossed.

Thank you for all the input folks and good to see positive feedback from the community.

1 Like

Yeah it’s close to unplayable I feel like hell after herbing for a little bit even with the reduced motion setting. It’s mainly they glide and turn aspect of it that does me in. The landing sound is grating as well since I have ear issues.

Have you tried going into accessibility options and playing with the motion sickness settings?

Switching to alternate full-screen effects, keeping the screen centered, and turning off dynamic camera movement should help.

It may also help to use a smaller mount (green or bronze dragonriding mount).

you can add this line to a macro for summoning the dragon riding mount:
/run for i = 14890510, 1489053 do StopSound(i) MuteSoundFile(i) end

(It disables the sound for that session, but it will return after you restart the game)

1 Like