Dawn of the infinite: murozond's rise bug

the trash leading to this boss me and my group couldn’t pass the room due to chromie not lowering the ice gate to the last boss stuck casting on the yellow blob

16 Likes

Just happened to me as well - had no aggro from any mobs anywhere. She just stays channeling on the glob and nothing ever happens

1 Like

Happened to us last night in a +10I submitted a ticket as I want my damned gorehowl

2 Likes

Just happened to us too, sadge

happened to us last night, bricked our key completely.

This was suppose to be fixed yesterday and its still broken. GG blizz
Wasted key

2 Likes

Just happened to our group 13 key 11/17 11:50pm EST

1 Like

Yep, just happened to me, a 13 with 10 minutes left. :frowning:

1 Like

Just happened to me in a +2. Not a massive deal but it’s the first mythic+ I’ve been brave enough to attempt since 10.0 :frowning:

just happened in a +6 for me 11/18 12:44pm pst

Just happened to me on a +11 - I am staring at Chromie and her time magic going into a blob and not ice walls >.<

Just happened to our +8 group, 13 mins left on the timer

Only a +4 but Blizz needs to fix this. Its not even a new dungeon surprised this wasn’t solved before now.

1 Like

Just happened to my guildies & I in a +4. Ice Wall just didn’t open. Won’t be doing M+ until this gets fixed :stuck_out_tongue:

This bug just ruined the key I was in , had 12 minutes left and wasted all of it trying to fix the bug

1 Like

I’m so mad. We just ran this on a 13 and got hit with the same bug. Chromie never opened the wall. We had over 10min left. I don’t have a lot of time to play this week and REALLY needed this key. :angry:

Worse, now the key is still the same on a 12 and I don’t know if I should bother trying to run it only to waste time again. :angry:

1 Like

Just happened to me

It’s something related to ret paladin ability’s… There was a ret in my pug who mentioned the instance has bugged for him every time he has ran it. It’s probably triggered by an ability similar to the adaptive swarm bug in halls of valor that prevented progression.

Same issue on my holy paladin, the door never opened to the final boss.

Just happened to my group as well on my pally.