Daily World Quest: A Dangerous Harvest

This quest is currently bugged. I have seen this bug twice already with different days. The button that transforms you into a moth does not appear when zoning into the quest zone. This quest is unable to be completed due to this, since you can not collect anima cones without transforming into the moth form. Please fix.

Bugged for me as well.

Bugged for me too.

You dont get the extra action button if you fly into the WQ area. You have to approach on the ground. Its still a bug, but the WQ itself is doable if you approach it that way.

23 Likes

Oh really? That might be it! I will try it out next time I do it.

Just experienced this as well. Can’t get the action button flying in. I had to get on a ground mount because even if i walk down the slope from Glitterfall Basin, my mount pops in the air at just the wrong time and I am in flight so the button does not activate. I guess you could also press the down button to ensure you stay on the ground on a flying mount as well.

Thanks so much it worked as of 4 October 2021 Dath’Remar Horde

Level 60 DK Zekita please ignore the other name and level it is not mine. TY.

Yep end of october and just did this, fixed it (I thought it was a UI issue). Thank you so much, still funny these types of bugs exist for so long though lol.

October 31 2021 quest still bugged.

Maybe development could spend less time on woke broke and goodwill social gesturing and fix flaws with the little content we do have.

1 Like

Or, you know, it might be something that is going to be part of the patch on Tuesday to fix the issue.

Been bugged since expansion release.

Maybe they’ll fix it a year later…maybe not.

I somehow have my doubt though.

Note: I also posted and sent a bug report in-game about this same bug back in December, so excuse me if I seem doubtful in Blizzards ability.

This works! Thank you.

This answer was worth coming here to read. Got credit in spite of Blizz’s worst efforts.

If you fly into the quest zone, you just have to log out and log back in and the action button will appear. You are welcome!

You dont have to log out, that just wastes time. Just fly out of the WQ area, to the point it disappears from the quest tracker, then go back in at ground level.

Still bugged 4/23 /2022

Leaving area didn’t work for me, nor did logging out then back in… Inexcusably dumb…

Make sure you are not on a flying mount. Geound mount only or walking.

May 2022 – this workaround still works! Thank you