Command-Click no longer working

Same for me. Mac Pro using a wireless mouse and cannot command + mouse click on anything. I’m glad I haven’t purchase Shadowlands.

1 Like

Hi friends,

Thanks for reporting to us about this Command click issue on Mac computers. We know that this is not a great thing to have happen and we do hope we can have a fix out soon.

For not, based on other users here, there are two workarounds for now:

  • Use an external 2-button mouse if possible
  • Double-finger tap (must be turned on in the Trackpad System Preferences)

Give these a try and please also add any advice, problems, or workarounds you find below.



1 Like

Yes, me too!

1 Like

On my iMac I have found that the tilde (squiggly line) key with the command key works as a ‘use’ feature. See if it works for you!

Man this is going to be a hard adjustment if it doesn’t get fixed somehow

1 Like

Just FYI, the command key is also used for targeting, which these work arounds don’t address.

For instance, when doing the WK “Beachhead,” holding down the command button changes the trackpad so that moving your finger on it controls the aim of the gun.

I’ve already done all of the BfA content and I don’t need rep, so it’s not like I need to do Beachhead, but it could be a problem in the expansion. The workaround for this is “use a mouse,” but I don’t even have room for a mouse on my “desk,” by which I mean TV tray. LOL


The double-finger tap option worked for me.

Hoping this gets fixed as soon as possible and glad to see a Blue post confirming.

1 Like

I’m wondering if it is now the default for CMD-click (not CTRL-click) to not work. One of the changes in the 9.0 client is that the CMD key is now independently able to be used as a keybind, which may well have broken the previous functionality those in this thread were expecting. Hopefully we’ll here back from Rommax regarding whether or not the new functionality is what has broken the old functionality.


Yep - same here. Still no guidance. Game unplayable. Good luck! If you find a fix, don’t forget to share!

1 Like

I play on a great big Mac with a mouse. (Wireless) Mouse is configured correctly but doesn’t function. No add-ons. Hope you have a fix soon, because…$$$ and I’m not getting any younger. Thanks.

1 Like

Bump! Please put out a hotfix soon x.x my bags are full! SOS!!!

Same Problem. Stacking up ‘Supply Awards’ from the daily emissary quests, but not able to open them with the keyboard shift command.

After reading thru the comments here, I tried the two finger tap suggestion wasn’t working for me when trying to buy/sell stuff to vendors, etc. Based on the comment about CMD being a bindable key, I found that the “left CMD” key was bound in Key Bindings/Chat to Voice Chat: Push to Talk. I changed the bind to require shift. I’m not sure if this really helped me for selling stuff, but I can at least buy stuff from the vendors with left command+clicking the trackpad.

Edit: I’m on a 2017 MacBook Pro. Also, I am changing my comment. The key bind change didn’t seem to help. The double finger tap DOES allow me to buy/sell stuff. As an interesting aside, the box on the vendor window showing the last item sold to the vendor does work with the command+click on the trackpad to “re-buy” things I sell to the vendor.

In the System/Keyboard option there is a Command Left Click as Right Click option, which I have checked. It seems to work in some parts of the game/interface but NOT in vendor windows at least. Couple that with the fact that Left CMD was keybound to System/Chat Voice Chat: Push-to-talk. I changed the key bind to add the shift key to see if it helped. It doesn’t. I suspect that the changes you mention may have messed with this option in the Keyboard setting, at least in some parts of the interface/UI. Frustrating.

There is a setting in System/Keyboard that specifically sets the Left CMD click as the right click. Also, Left CMD is key bound to System/Chat Voice Chat: Push-to-talk by default. I think there are some conflicts here that y’all need to check. And, as I mentioned below, Cmd Left click does work in some interface parts (like buying back a sold item on the vendor window) but not buying a NEW item on the same window. Only the two finger tap works for buying/selling stuff. I hope this helps your guys find and fix this.

Idk if this has been mentioned but I can use cmd click to click to move or to right click on a group in premade group finder. It seems like it works with everything except right clicking on things in my bags and trying to buy off a vendor.

I believe the only reason it works with buying an item back is because you don’t need to right-click to buy an item back, you just have to click the item normally.

Double tapping (2 fingers) on trackpad works for me. Yay.

While Double Tap (2 Fingers) worked, it is by no means a long term solution.

Cmd + Click needs to return immediately.