"Cleansing the Mother Tree" quest bug

I found this thread because I was stuck clicking the icon for the G'Hanir staff on my action bar, unable to complete the quest.

I used /reload ui a few times so I'm not sure if that made any changes.

I finally noticed a small Icon for the staff in the drop-down menu for the quest. After clicking that icon, the quest finally completed and I have the staff now.

So, I believe some of you may be in the same spot, clicking the Icon on your actionbar, the staff itself, or the icon in your abilities menu doesn't seem to work. You must click the button from the quest drop down which says something to the effect of "call upon the spirits of the forest" to actually complete the quest.

Sorry if this is redundant, I just wanted to help in case anyone else finds themselves stuck.
2 Likes
Having maybe a different issue. I have already completed the scenario and it wanted to turn in. When I tried to turn it in, it restarted the scenario. Now, I have a completed quest that won't turn in or abandon and a scenario that I can't complete because my G'hanir is no longer corrupted. Tried reload. Tried force quitting and logging back in, tried the /click ExtraActionButton1 where the quest is supposed to be turned in at and nothing.

Because I'm in a scenario, I can't leave the area and my "druid party" is forever stuck in the phase where no one is taking damage and just waiting for me to do my thing with the Stave. Any ideas?

EDIT:
So I had to hearth stone out and then fly back to the Dreamgrove from New Dal to turn in the quest.
1 Like
Same problem, stuck on Destro. Reload fixed it, thanks guys.

Yup, it was my addons interfering. as soon as i disabled, and reloaded, worked like a charm. Thank you!

This thread just saved me haha, thank you. The objectives had collapsed and I didn’t see the icon. Had no idea what to do.

This quest is still bugged, no addons and still bugs up, WTF Blizzard?

This did it for me, thanks a lot!

I just got to the end of this quest and beat Destromath, but I don’t see a turn-in anywhere, I’m still in the NPC’s “party”, and the quest is telling me to “Take the portal from Nordrassil to Orgrimmar”, which is an optional step of the quest. The rest of the quest steps are checked off. I can’t abandon the quest because that button is grayed out, so I’m not exactly sure what to do now…sigh.

Also, my tag here is the wrong toon. Should be “Hectre 12 Troll Druid”

UPDATE
I had to hearthstone to Orgrimmar, then Dreamwalk to the Dreamway, and take the portal to Dreamgrove. Then I was able to turn in the quest. WOW!