Can't upgrade tiered gear even though I meet requirements

They are reading the forums. You are not.

We are currently investigating an issue where PvP gear can’t be upgraded. When hitting the upgrade button the error message “This item can’t be modified” appears. Currently, we do not have a workaround or resolution that can be provided. We apologize for any inconvenience while our developers work as quickly as possible to resolve the issue.

They posted that under “can’t upgrade pvp gear” in support section

thanks for the find

Link for my fake news friends.

Tambem estou tendo o mesmo problema.
Neck não upa do 8/12 para o 9/12.
Atendo todos os requisitos de IO.

It’s happening to me right now on one of my toons. Just managed to get the item to 239 but can’t go further!

Having the same issue in Korthia

Any update on this? having this issue with 2 items a pvp belt and ring, i upgraded all my other pvp items but those are broking out.

This has nothing to do with this post lol

Yeah this really needs to be hotfixed, many of my alts including this rogue are hardstuck in spite of having the currency and items to upgrade…

still no fix… hope they give us bonus currency for the hassle :stuck_out_tongue:

Same problem but with pvp gear.

They should put a blue post to one of the multitude of Bug reports so places like Wowhead and others know its actually out there. When I first reported my issue, that site was not updated. And they usually close tickets saying go post on bug forums. So why would people check the support section?

same issue. This should be addressed

What do you mean it as nothing to do with the post. Everyone is getting the same warning for “this item cannot be modified.” Doesn’t matter if it’s pvp or pve. Their upgrading system is having issues.

I just googled it and found it. Took a minute.

Seems to be working now

1 Like

fixed form me now after a small update.

No not everyone is getting the same warning and not everyone in this thread is talking about PvP gear. Plenty of PvE and Korthia gear mentions. Some people were getting an error message but plenty of others were getting no message or alert or anything whatsoever.
As the OP mentioned at some point in this thread it seems to do with pieces of gear that have sockets regardless of what kind of gear it is.

I was able to get my upgrade pieces to work now (bracers, belt) after the Nov 10 hotfix. I don’t think it was mentioned that it was fixed in those notes but I guess it works now…

1 Like

Yep, looks like this is fixed guys! I just upgraded all my gear today.