Auction House: Items not available (but they are)

This just started happening this morning after the update/maintenance, but when I go to the AH and open it up, on my first page where I have all my favorites, it says the following items are unavailable: Darkmoon Daggermaw, Tidespray Linen, Enchanted Lightless Silk, Silvergill Pike, Elysian Thade & Lightless Silk.

But when you click on the items, a bunch of auctions show up.

Those are the only items I have “favorited” that say “None Available”. All of my other favorites show up- with their auctions- just fine.

12 Likes

It would appear that all the items I see affected by this are items used in crafting. Making it a royal pain in the posterior to check to see if an item is profitable to make with out using a skimming addon to assess prices for you.

3 Likes

Have you tried a Full UI Reset to rule out any corrupted files that could be affecting your issue?

2 Likes

Same thing here. If I add one of the crafting items to the auction, it’ll return to the Favorites list, but there are lot of them.

2 Likes

Same problem here, and it first showed up after server reset this morning.

2 Likes

Same here. I did try the full reset and that did not help.

2 Likes

Same here.

I’m having the same issue . I’ve updated everything, even deleted my cashe and WTF folders and tried going in with out any addons at all. It seems to only affect crafting mats.

2 Likes

Same as above.

1 Like

I found something interesting and related this morning.
These items when you right click them on your Favorites list are showing up as do you want to remove. When you left click the item shows up then right click on the item in that window and it is showing it can be added to favorites doing so will add a duplicate item to your list that works as you expect. You can then remove the old non functioning markers you had listed as favorites. When removing items be sure you only right click the item that doesnt work on the Favorites list do not go into the list of items for sale or you are removing the correctly functioning item from your list.

Hopefully you dont have to perform this solution because its gets fixed under the hood before you read this but else this appears to be a solution.

8 Likes

No, I had not tried that, and thank you for the suggestion. However, judging by other peoples’ responses, it doesn’t seem to fix anything.

Thank you Tabluz, this works for me. It’s tedious but it works.

1 Like

I confirmed this works for me. I was able to purely search for the items in my list and re-add items to my favorites by clicking the star a couple times.

1 Like

The WoW version of “did you unplug it then plug it back in again and turn it on?” I feel silly for not thinking of this :joy: :woman_facepalming: Thanks for the tip- it worked!

1 Like

In order to address an issue where some Shadowlands commodities weren’t properly sorting ahead of other items in the Reagent Bank, we changed the item level of those items. This had the unexpected result of making existing player Auction House favorites entries for those items invalid. We’re going to work on making the favorites system more resilient in the future, but in the meantime, players can re-favorite these items and it should fix the issue.

16 Likes

That’s what I ended up doing when I saw the problem after the update. Was odd to see, but an easy fix.

same thing has been happening to me. around ten of my favorites will load with a price and the rest on my list have the price as “none available”. so i was able to fix it by clicking on the greyed out item, right clicking on the portrait of the item and hitting set favorite.
not seeing all the auctions was driving me bonkers.

Thanks this worked. To all who do this, be careful not to unfavorite a fave you had before that really isn’t available, otherwise you lose it from the favorites and have no way to favorite it again until it’s available. Kinda disappointing as I was keeping track of some items not usually for sale. Learned the lesson the hard way. (so check availability first before removing the old fave IOW).

1 Like

This worked for me. Thanks!!